No power to stepper motors

I am currently attempting to power two 12V .4A stepper motors using an Arduino Mega and an Adafruit motor shield. I had a similar setup working about 2 months ago, and everything was working fine. Now, with this new setup, there is no power going to the stepper motors. I have tried using two different Arduino Megas, two different motor shields, and two different motors. Still, nothing works. I tried powering my system from two months ago (I had changed nothing, except disconnecting a motor shield and putting it back) and that no longer worked either. This leads me to believe that the motor shield is not working correctly, but I don't know how to check this. I also wonder if there is something wrong with my program, but I ran the one from two months ago (that worked before) and that didn't work. I really don't know what to do at this point, because I don't want to order yet another motor controller, build it, and have it not work. Can someone please help with this problem? I can provide diagrams and other information if needed. Thanks.

Hmmmm I know very little (read as: nothing) about steppers and their shields but.... the one thing you didn't mention in the whole explanation of diagnosing a power problem was the power supply.

Did you try different sources of power? Could it be that the common thread across all the combinations of Megas, shields and motors is the same source of power?

So, after a few more attempts at connecting my old project, it seems that the motor, the motor shields, and the power source are all working okay. However, when I went back to use my new Arduino, the motors would not turn. The program was compiling fine and running through, just the motors weren't turning. I realized that the code on the old Arduino was uploaded with a different version of the Arduino software. I attempted to upload newer code onto the old Arduino, and the motors no longer worked. I think that either the drivers for the Arduino are not compatible with the Adafruit library, or the version of the Arduino software. Does this seem like a reasonable conclusion?

Is the old Arduino also a Mega?


Yes, the old Arduino was a Mega. I finally got the setup working. Apparently there was a newer version of the Motor Library, but I didn’t notice that it was new, since there are no version numbers for the library. I only noticed when there were more examples in the examples folder. In any case, thank you for your help; I really appreciate it.