No response from NG-USB

Hi there. I have a bunch of older NG-USBs here at school (with atMega8s). I have been trying for ages to get even the blink sketch uploaded, but no dice. Here's the setup:

  • I have the board connected through a regular USB A-B cable. When I plug it in after clearing all serial drivers with FTClean, I get the "found new USB to serial converter" message.
  • I install the FTDI drivers from the folder that comes with arduino 0010. It installs twice it seems - I install the bus driver first and then the port driver? (FTDIBUS.INF followed by FTDIPORT.INF). I am not sure about that step. In any case, it shows up as a COM port device.
  • I set the COM port to 9600 baud, though I have also tried 19200.
  • I set the Arduino IDE to "Arduino NG or earlier with atMega8"
  • I set the com port to the one that shows up when I plug in the arduino
  • when the board is plugged in and powered, the LED on pin 13 blinks in a way that I don't think I've seen described. It strobes very very fast, I think 3 times, every 8-10 seconds or so. It's so fast it almost looks like a single flash, but you can just discern the strobing. It is definitely not the slower blinking I've seen on some other chips.
  • I have tried pressing the reset button at all sorts of different times before and after clicking upload.
  • I have swapped out the atMega8 for other ones on older (Serial) boards that have worked in the past. They have the same strange blinking.

The little Tx light blinks a few times when I first send the sketch over, then once every 5 seconds or so; Arduino returns the error

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

It seems like the only thing left to try is reburning the bootloader, which I don't know how to do. Is this weird fast blinking a sign of the wrong bootloader or something? I would think if there was none, it wouldn't blink at all.

I also have a diecimilia that blinks the proper way, but it belongs to someone else so I can't use it :)

I am planning to try more chips to see if the bootloaders are wrong, but I dunno if that will work...

Thanks for any help -- this is driving me nuts.

It sounds like you’re doing the right steps, which makes me suspect the computer (since you’ve tried lots of boards). Can you upload to the Diecimila on that computer? Can you upload to the boards on another computer? Are you running any virus scanners / PDA sync applications / firewalls? Some or all of those could be blocking access to the COM port.

The blinking is right - that’s the pattern for the NG bootloader (I should document those somewhere). The two-step driver install is also correct (I think one is for the FTDI chip on the board as a USB device, and the second for it to show up as a COM port / virtual serial port).

The upload takes place at 19200 baud. Where are you setting the COM port to 9600 or 19200?

I’m setting the COM port speed in the driver properties (Control Panel > Administrative Tools > Computer Management > etc – I’m on WinXP). I tried again with it at 19200, but still doesn’t seem to work. I also replaced the fast-strobing chip with one that blinks three times @ ~1hz, every 8-10 seconds. Which bootloader is this one running?

I’ll try both chips at 19200 and let you know whether I can program the diecimila with this computer, when I get permission to erase what the other guy has on it :stuck_out_tongue:

I should also mention that when I set the IDE to “Arduino NG or older w/atMega8”, or anything else for that matter, I get a load of warnings about Firmata.cpp and a pile of other things in /arduino/avr/bin/. Is this the issue, or are these normal warnings?

Ok, I found a diecimila that was still in its package (sealed). Plugged in, it went through the install process automatically, I assume cause the drivers were already there. In this case, I didn't even restart the IDE...just changed the COM port and board and hit upload, and bam it works great.

I suppose this is why the diecimila was invented, eh? :D

So immediate problem, of getting an arduino that I can use to prototype with, solved. However: still no dice on the older ones. Any ideas? Turns out we have an AVRISP - should I try to reburn the bootloader? It seems okay from the light patterns.

Hmm, you might try the NG on some other computers, too (maybe under Mac or Linux). Reburning the bootloader might help too, though it sounds like it should be okay.