No result when using GET method with Ethernet Client


I'm trying to get data from WCF webservices on port 5053. And It will return in JSON format.

Here my snippet code :

char server[] = "";    // Example  DNS server
void setup() {
 // Open serial communications and wait for port to open:
   while (!Serial) 
    ; // wait for serial port to connect. Needed for Leonardo only

  // start the Ethernet connection:
  if (Ethernet.begin(mac) == 0) {
    Serial.println("Failed to configure Ethernet using DHCP");
    // no point in carrying on, so do nothing forevermore:
    // try to congifure using IP address instead of DHCP:
    Ethernet.begin(mac, ip);
  // give the Ethernet shield a second to initialize:

  // if you get a connection, report back via serial:
  if (client.connect(server, 5053)) {

    // Make a HTTP request:
      client.println("GET HTTP/1.1");
      client.println("Content-Type: application/json; charset=utf-8");
  else {
    // if you didn't get a connection to the server:
    Serial.println("connection failed");

void loop()
  // if there are incoming bytes available 
  // from the server, read them and print them:
  if (client.available()) 
    char c =;

  // if the server's disconnected, stop the client:
  if (!client.connected()) {

    // do nothing forevermore:

When I run the arduino, is only show "Connected" but no result.

If using the web browers, it will show : {"JSONDataResult":"You request the product with ID: 1234"}.

Did I do something wrong?

Problem solved.

Perhaps you could enlighten us so future users of the forum can benefit from your efforts?

I suspect the fix is to send a valid http GET which is terminated by a blank line and the required new line chars, which from memory are \r\n