No serial port & reset button doesn't work

Hi - I'm unable to load a sketch onto my Arduino Duemilanove and will appreciate advice on next steps. The two clear symptoms I'm seeing are:

  • The USB-based serial port does not appear in the Tools > Serial Port menu
  • Pressing the reset button on the board does not seem to work. The L LED does not show any change when the button has pressed. I've tried various lengths of time and combinations of plugging / unplugging the board while the button is down.

Things I've tried:

  • Reinstalling the Arduino IDE
  • Uploading from different computers (an iBook and an iMac)
  • Using different USB cables
  • Reinstalling the FTDI drivers & restarting
  • For the reset problem, connecting with either USB or 9v

My best guess is that this is a problem with the bootloader - that it has to be present in order for the USB serial port to work, and for the reset button to respond. Am I on the right track? If so, is there a way to restore the bootloader without buying additional hardware?

As some additional background, I've been playing with flashing grbl ( ) onto the board using AVRDude. I set aside the project several months ago, so my memory is fairly hazy. But if I remember correctly, I was able to run grbl, and then replace it by uploading a sketch using the standard Arduino IDE.

I think my next step is to either buy a programmer or a second board (to act as a programmer) - and restore the bootloader. But before I do that, I'd appreciate any advice on whether there are other things I could try first?

Thanks! Chassy

Full configuration: Arduino Duemilanove with an ATMEGA328p. Arduino 22 on both an iMac running OS X 10.7 and an iBook running OS X 10.4.

Chassy: The USB-based serial port does not appear in the Tools > Serial Port menu[/li][/list]

Have you tried using another USB cable? Because if the USB serial doesn't appear on the menu, that's one of the possibilities. You've already covered another one, by re-installing the FTDI chip drivers.

Yes - I've tried 2 USB cables from 2 different computers.

Is the FTDI chip on the Arduino (near the USB connector) getting hot? Sounds like it may have failed.

It's quite warm after the board has been plugged in to 9v for about 10 minutes.

If that's the symptom of a failed chip, then it sounds like I'm getting an Uno. That said, is it still possible to flash the board with the blown FTDI chip, but using another Arduino as an ISP? Or is it junk now?

The root failure to concentrate on is that the PC does not see a new USB connection being made when the board is plugged in, correct?

If so the problem is either software based on the PC (and it sounds like your tried everything possible for that) or a bad USB cable (you tried that) or a bad FTDI chip on the board. It has nothing to do with the 328p processor chip, the PC should ‘see’ the board connection even if the 328p is removed from it’s socket, so reflashing the 328p is pointless at this time, a problem with the bootloader would not prevent the PC from ‘seeing’ the board when first plugged in. Nor does the reset button have anything to do with establishing a USB connection to the board, pressed down continously, not pressed, pressed for just a second, all that wouldn’t cause or prevent a USB connection from being established. I assume you tried to install the board to a different USB port on the PC? If not, try that.

The FTDI chip is not reflashable, it is a remove and replace component and because it’s a SMD packaged chip, very difficult for most of us to unsolder and replace.

So the things you have done to try and solve the problem make sense, but I don’t think that there is anything else you can try. The FTDI chip being ‘quite warm’ is also a sign that it is the root cause of the failure. The FTDI chip appears to be ‘tits up’, sorry.

That said, is it still possible to flash the board with the blown FTDI chip, but using another Arduino as an ISP? Or is it junk now?

Yes, it is possible that the board could be used that way, if the only problem is the failed FTDI chip. It’s also possible to use a USB TTL serial cable to upload sketches from the arduino IDE. The only cavet is with the FTDI chip not functioning is impossible to say if there are any other hardware/firmware failures on the board additionally. The only common method of toasting a FTDI is by somehow applying voltage above the safe amount, and that could very well damage more then just the FTDI.


Thanks Anachrocomputer & Retrolefty! Next step… a brand new Uno to power a a 15’ tall talking PEZ dispenser. You’ve also given me a little more insight into the Arduino platform itself.