No serial port shown for Arduino Uno from Starter Kit with Mac OS X High Sierra

Problem solved - thanks, Mitel!
It turned out to be a usb cable connection. The printer end needed to be pushed about a millimeter further in to its socket to get a complete connection which resulted in the right port showing up in the ports list. I thought I had a good connection because the Arduino green light was on and the yellow light was blinking, but I was mistaken. The connection needed to be just a little better.

The original problem was:

I am happy for some help:
Problem No appropriate serial ports are shown in the Tools:ports menu when I connect brand new Arduino Uno to MacBook Air running OSX High Sierra.

The Arduino Projects book that came in the starter kit states that I should find a /dev/tty.usbmodem type serial port listed, but do not see one in the list.

I have tried rebooting with Arduino plugged into computer, and unplugging and replugging. I searched Google and found some users able to fix the problem by installing a driver for CH34x chip and tried this install with no change in the result. I have tried using the serial port which does appear, but get an error message when trying to upload the Example: Blink file to the Arduino Uno. The error message is Arduino: 1.8.5 (Mac OS X), Board: "Arduino/Genuino Uno"

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "/dev/cu.PPA10BT-SerialPort": Resource busy
Problem uploading to board. See for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

The Arduino does have the constant green light and blinking yellow light, so I am assured that the usb port I am using is sending power to the unit.

Starter Kit 1 x Arduino Starter kit ENGLISH (8058333491318) was purchased directly through Arduino with order number Your ARDUINO STORE by BCMI LABS SRL order is being processed (100014068). The included book says that no drivers are needed for Mac OS X.

Please help me get started using Arduino.
Lori Cook

You'll want to Google this.

The topic has come up before.


First thing I would try is a different USB cable (although I suppose you used the one provided with the kit, which should be ok, but you never know).

Also - is that the official store you say you bought from? If not, check the part number on the black chip near the USB connector (atmega 16u2 means it's an official or faithful clone, CH340G or CP2102 need a different driver)