No TCP/IP link,without pressing the reset button

I have just get my first Arduino boards, Duemilanove and a Arduino Ethernet Shield. I have installed the Windows software and loaded the Web Server example to the unit. Everything worked fine and I was able to communicate with the unit from Windows Explorer when I had the USB cabel connectet to my Laptop (with drivers) But when I try to power the units from a routers USB port (I just want 5V from the router) I have to press the reset button on the Ethernet Shield to have the Ethernet up and running. The router have no drivers for the Arduino units. ??

Your USB port may not be able to provide enough power

What kind of router do you have?

:)

It's no problem with the power I got 5 Volt from the router. The router is an Dlink DIR-451 mobil broadband. It seems that when I have the USB cabel connected to the PC there are some handshaking who trigger the Ethernet link to go up.

Have you tried using an external power supply?

The Duemilanove can take 6-12VDC from an AC to DC adapter using the power plug on the edge of the board -- make sure you move the PWR jumper from USB to EXT PWR

Please give it a try and let us know if it works

:)

I got 5 Volt from the router.

That's half the equation - how much [u]current[/u] do you get?

I second (or third) the recommendation to try a different power source.

-j

Same result with external power, the "FULLD" Led is blinking until I push the reset button.

I have done another test, external power and then I have cut of the power cable (pin1 VCC) from the USB cable. Same result when I connect the USB cable to my PC the link go up! It seems to be some magic talk between the board and the driver in the PC. No program is running in the PC.

Time to post your code...

-j

Some pictures may help too :)

http://flickr.com/ is good for high-res pictures

:)

Here comes the code, I have just changed the IP address from the example:

/*

  • Web Server
  • A simple web server that shows the value of the analog input pins.
    */

#include <Ethernet.h>

byte mac = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
byte ip = { 192, 168, 0, 120 };

Server server(80);

void setup()
{
Ethernet.begin(mac, ip);
server.begin();
}

void loop()
{
Client client = server.available();
if (client) {
// an http request ends with a blank line
boolean current_line_is_blank = true;
while (client.connected()) {
if (client.available()) {
char c = client.read();
// if we’ve gotten to the end of the line (received a newline
// character) and the line is blank, the http request has ended,
// so we can send a reply
if (c == ‘\n’ && current_line_is_blank) {
// send a standard http response header
client.println(“HTTP/1.1 200 OK”);
client.println(“Content-Type: text/html”);
client.println();

// output the value of each analog input pin
for (int i = 0; i < 6; i++) {
client.print("analog input “);
client.print(i);
client.print(” is “);
client.print(analogRead(i));
client.println(”
");
}
break;
}
if (c == ‘\n’) {
// we’re starting a new line
current_line_is_blank = true;
} else if (c != ‘\r’) {
// we’ve gotten a character on the current line
current_line_is_blank = false;
}
}
}
client.stop();
}
} :-X :-[

I don't know the Ethernet library, but there is nothing obvious to me wrong with the code.

Try putting a resistor, 1k to 10k, between arduino pin 0 and ground (but only when the arduino is not connected to a computer for programming, etc).

I wonder if some noise on the RX line is causing the bootloader to hang. If your router is a wifi router, there could be plenty of RF noise to go around.

Does a single press of the reset button fix it every time, or do you have to try a few times before it starts working?

Do you hook up the ethernet cable before the USB cable? maybe try powering up the Arduino before you plug in the ethernet cable. If this seems to help, put a delay() of a few seconds in setup() to see if that helps.

-j

Great advice kg4wsv

A Faraday cage would also help :)

I have tried all proposals without any success. I have even switched to another router. Only USB connect or ONE single push on the reset button start up the ethernet link.

Sorry, I'm stumped. I see no reason for the behavior you observe.

Which ethernet shield are you using?

-j

It's a Arduino Ethernet Shield. See picture on attached link

http://www.electrokit.se/images/12200080.jpg

I order a new Ethernet Shield card and now it's working! ;D

I, too am experiencing this same issue. It is an arduino ethernet shield (wiznet with the sd card slot). I have written some very simple tcp code, that does not work on power up, but works just fine if you then press the reset button, ground the reset pin, or open a serial connection.

Should I contact my vendor, or is it possible to fix my unit?

Even with my new hardware I seem to have the same problem. I have to push the reset button or connect the USB cabel to have the Ethernet link up ?? :'(

This sounds similar to a problem I had with my home-brew ethernet board (using the Wiznet module). I had a 3.3V regulator that was too small and had to add a 200ms sleep in setup() to get it to work reliably.

The Arduino ethernet shield's 3.3V regulator is not undersized, but I wonder if there is some similar issue? The Wiznet chip seems to be a bit picky about low voltage, and it's a bit hungry at 138mA to 183mA current consumption. It also needs 10ms from the time reset goes inactive until PLOCK is good. (I assume that's a PLL lock? no other mention of that parameter in the datasheet.)

Anyway, just as a wild guess, try putting a delay() in setup() to see if that helps.

-j

Unfortunately the delay does not help. I tried up to 20 seconds before calling Ethernet.begin().

It's really disappointing because the ethernet shield is such a potentially cool piece of hardware, but it's not very useful if one has to press the reset switch after every power up.