NoClassDefFoundError: processing/app/Base (Debian)

I try to install arduino IDE in my debian SID with this how to:

then I install the package sun-java5-jre sun-java6-jre librxtx-java

but when I run /usr/lib/arduino/arduino , I get an error:

Exception in thread "main" java.lang.NoClassDefFoundError: processing/app/Base

Where is the problem????

I try again with the copy in the svn ( arduino-0009 ) and I get the same error:

Exception in thread "main" java.lang.NoClassDefFoundError: processing/app/Base

I'm not sure quite how the debian package is set up, but it sounds like you need to add a directory to your CLASSPATH environment variable. There should be a pde.jar somewhere from the Arduino package, and it or the directory it's in needs to be in your classpath. You can try something like in a terminal:

export CLASSPATH=/usr/lib/arduino:$CLASSPATH

And then run Arduino.

Thank you for the idea !!

I run it, I edit the file arduino an put at the end in the line CLASSPATH:


Only work if I run it since the path /usr/lib/arduino, but .... RUN !!! ;)

You will see this problem if you start arduino from outside of its "home".

e.g. if you don't want to fiddle with CLASSPATH, this should work:

$ cd /path/to/arduino-008/ && ./arduino

Rgds, Ben