Nodemcu Error and Arduino15 file

ERROR :
pyserial or esptool directories not found next to this upload.py tool.
pyserial or esptool directories not found next to this upload.py tool.

I have seen these errors when I have compiled my nodemcu. I have find a solution but I cannot find the Arduino15 file on my Mac. I have tried cmd+shift+. for hidden items too. But there is no Arduino15 file on my Library or Home file. How can I find this file and solve this issue. Thanks for your attendance.

If you installed the esp8266 boards platform correctly, you should not ever get this error. I suspect that for some reason you did the "Using git version" method but didn't follow the instructions correctly, so the submodules weren't initialized.

The "Using git version" method is only to be used by developers. Normal users must follow the Boards Manager installation instructions. So please delete the "git version" installation you did and then install the esp8266 boards platform by following these instructions:

Note that you must stop before you get to the "Using git version" section of the instructions. That is an alternative installation method.


Now to answer your question about how to find the Arduino15 folder. This folder is indeed under /Users/{username}/Library/Arduino15. Here's an easy way to get to it:

  • (In the Arduino IDE) Open the "Arduino" menu from the tool bar and click "Preferences".
  • Click the link on the line following "More preferences can be edited directly in the file".

I don't think you will need to access the Arduino15 folder to fix this particular issue. It should be fixed once you use the correct installation method. However, it is useful to know where this folder is and how to access it.

Still no success.
ESP8266 installed correctly from Boards Manager.
Opened "Arduino15/packages/esp32/hardware/esp32/1.0.4/libraries/platform.txt" and changed the second line to esptool.py as instructed.
" 1. Open this file: /Users/yourusername/Library/Arduino15/packages/esp32/hardware/esp32/1.0.2/platform.txt and change the line that says "tools.esptool_py.cmd=esptool" to "tools.esptool_py.cmd=esptool.py""
(Reddit says 1.0.2 but presumably mine is more recent).

Reddit then says " Search for esptool.py on your system and copy it to this folder: /Users/yourusername/Library/Arduino15/packages/esp32/tools/esptool_py/2.6.1". I have that folder but the only file in it is "esptool", a Unix executable file.
Reddit says 1. Open that file. Change the very first line to #!/usr/local/bin/python3", but I think that's for the esptool.py file?

Rapidly getting out of my depth. It all used to work so well!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.