NodeMCU pin 2 not outputting

Hi all,

I'm working on moving my breadboard "prototype" to a more permanent setting, aka a box. In order to do so, I soldered my components on a solderable breadboard then connected it to my NodeMCU. When I ran my program, pin D2 on my NodeMCU seems like it wasn't giving out any signal because when I measured the voltage from that pin it was giving out a negative voltage (which I interpreted it as not actually giving out anything..).
When I ran the program on my breadboard "prototype" instead of my permanent setting, pin D2 gave out a signal of around 3 ish voltage. Now granted it's a different NodeMCU.

Do you guys have any idea of what I might be doing wrong? Or is it just that pin not working. I tried pin D1 and D3 too, they didn't work either..

Thank you in advance!

Slow down and stop!
Please read the first topic telling how to get the best from this forum.
You produce a word sallad and helpers wants scientific facts like code, wiring, links...

If you have read a negative voltage, re do the test again. Make sure the -Lead is on circuit common. If you get the same reading, again, then you have crossed wires/connection. Track down where the voltage turns from +V to -volts and do not discard minus voltage readings when dealing with +voltages. Those -volts tell a story.

Oh, and be ready for the MCU to be fried if a -V got into the MCU.

Updated: it's not the MCU problem. I took it out and use it on my breadboard prototype and it worked fine so it must be my soldering work or as you said, something about crossed wires/connection. Do you know where can I start with tracking?

Thank you!

Start disconnecting things. Then check the basic part, add one new piece, check and so on.

With a multimeter and a schematic, start at one end and move forward. I'd use ohm measurements instead of a powered circuit to make measurements.

Post a schematic, post a pic of the project.