Noise in audio if I feed audio (PWM output from an audio module) to mic

I am feeding audio from a Sound module wtv020sd-mini which is PWM , to the mic Pins of My GSM Module Sim900, when I hear this sound on a a speaker although its not a high quality still its fair enough, but when I play the same voice and feed it to Sim900 mic and listen to it over a call its quality is very poor, there are alot of humming sounds and voice quality itself is also low.

I wanna use the module for voice response to callers , Is it all because of PWM output ? I used another module from ISD17150 and its voice quality is very nice even on the call.

That link is bad.

So I am unsure what you mean by "which is PWM" It is unlikely that the output is actually PWM.

but when I play the same voice and feed it to Sim900 mic

Again it is not clear what you are doing. You seem to be saying that you are feeding a sound signal into a microphone and using it as a speaker. Surly that is not what you are doing?

@Grumpy_Mike I am finding bits like this all over but no detail and no resolution.

guidance on how best to achieve this with reasonable quality audio over gsm and no physical speaker.(Other than on the mobile phone receiving the call.

this sounds like hes playing an audio signal down a opwm pin to the mic of the sim900 gsm unit which is similar to what I think I would need to do.

The audio quality appears to be a frequent issue, probably because its not correctly connected properly and the sketch not fine tuned???

@Grumpy_Mike I am finding bits like this all over but no detail and no resolution

Please do not hijack long dead threads.

I am not sure what detail you need. Please resume the discussion in your origional thread. It is clear you are not understanding things being said, we need to establish what you do not understand, but in your own thread.

okay point taken about old threads