Non vuole flashare ESP8266

Buonasera, è da un po' di giorni che ho acquistato per provare ad integrare il WiFi su Arduino:

  • 2 schede WiFi ESP-01 ESP8266 (non tutte subito ma la seconda scheda l' ho comprato dopo aver creduto di aver bruciato la prima).
  • Un adattatore per ESP-01 chiamato ADP-01 che potete trovare cliccando qui. Praticamente converte da 5 Volt a 3,3 Volt per dare la corrente giusta in modo da poterlo alimentare senza problemi con Arduino (anche se io l' ho sempre alimentato esternamente) e inoltre impedisce di bruciare la scheda WiFi collegandola al TX e RX di arduino che vanno a 5 volt.
  • Un "convertitore USB-Seriale" che però non supporta i 3,3 Volt quindi lo collego solo RX e TX e poi alimento esternamente.

Ho provato questa guida per provare a flashare ma senza successo. Ho cablato come indicato, ma niente, sembra che non riesca a comunicare il esp01 con il PC.Seguendo invece un altra guida che ho trovato su internet, ho provato anche a usare i comandi AT con il "Serial Monitor" di Arduino IDE, ma escono solo lettere a caso.

Spero di poterlo usare, perchè non ho idea di come farlo funzionare.

**@XuRi: **non avendolo tu ancora fatto, ti chiedo cortesemente di presentarti QUI (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con attenzione il REGOLAMENTO ... Grazie.

Guglielmo

Grazie del consiglio, mi sono appena presentato

Devi collegare anche il GND del convertitore seriale altrimenti il livelli del segnale potrebbero non corrispondere.

Ok qualcosa è cambiato, anche se non flasha ancora niente e non mi da nessun risultato sul “Monitor Seriale” usando i comandi AT. E’ apparso invece un rete Wifi di nome “AI_THINKER_81A1CB”. Ho fatto i seguenti collegamenti.

ADATTATORE “ADP-01” per “ESP-01” <=> Scheda Wifi ESP01

TX (Adattatore) <=> TX ( Convertitore seriale )
RX (Adattatore) <=> RX ( Convertitore seriale )

  • (Adattatore) <=> VCC ( Convertitore seriale )
  • (Adattatore) <=> GND ( Convertitore seriale )

P.s. Ho provato anche la mia prima scheda wifi che credevo morta e sembra dare li stessi risultati.

Aggiungo che stessa cosa anche collegando in questo modo

TX (Adattatore) <=> TX ( Convertitore seriale )
RX (Adattatore) <=> RX ( Convertitore seriale )

  • (Adattatore) <=> VCC ( Convertitore seriale )
  • (Adattatore) <=> GND ( Convertitore seriale )
    0 che corrisponde a GPI0 (Adattatore) <=> VCC ( Convertitore seriale )
    EN che dovrebbe corrispondere a CHIP_ENABLE (Adattatore) <=> GND ( Convertitore seriale )

Prova incrociando TX con RX e RX con TX.
La velocità della seriale dovrebbe essere di 115200.
GPIO0 va a GND
CH_EN va a VCC.

Sul monitor seriale devi anche selezionare CR+LF.

Wow, sta funzionando, la scheda wifi finalmente mi parla dopo giorni ahahahahah :smiley: