Not able to establish a secure (HTTPS) connection

New users; father and son.

we cannot get the editor plugin to function properly. Weve downloaded and installed several times. The errpor message said to post to the forum so here we are…dead in the water.
Any help would be appreciated.

Screen message upon trying to open editor:

"Something went wrong

We are not able to establish a secure (HTTPS) connection between the Plugin and the Arduino Web Editor. You can try to restart your browser once more, or Download the Installer and run it again."

Hi blackbug

That message would indicate a few things.

Just take a run through this post first and add any extra details that are mentioned in there.

It does sound like a plugin issue.

During the plugin install did you ACCEPT the things it offered such as CERTIFICATE, FIREWALL, DRIVERS etc.

Also just for the plugin install could you try "run as administrator" if you are on windows....You can google that for your flavour of windows its an easy thing to set up and do. NOTE that this is ABOVE a user with admin privileges !

Please let us know at least your OS and browser so we can try to troubleshoot your issue, thanks!

Using
Chrome Version 59.0.3071.115 (Official Build) (64-bit)
Windows 7

Saw the message in the attached screenshot multiple times. Tried re-installing multiple times, ran the installer software as administrator to install, ran the plugin as administrator to launch, but the web browser doesn’t seem to be able to talk to the plugin.

It seems to be an issue possibly with your computer or ISP.

What is your connection jacob ?

Also try chrome in an "incognito window" to rule out any chrome add ins.

Also try with your computers security / antivirus turned off.

I will presume you accepted the certificate install and the drivers it may have offered as without those you might not get far.

I have the same problem - I get the error message "We are not able to establish a secure (https) connection between the plugin and the Arduino web editor" when trying to install the web editor plugin.

I have reinstalled the plug-in, installed as an administrator, and run chrome in incognito mode, and no success.

I can't find anything on the message boards about a successful resolution to this problem - any ideas?

Thanks!

Mistral

Did you accept the certificate ? Did you let the agent create a firewall rule ? Did you accept drivers as and when they are offered ? What type of internet connection are you using ? What type of security do you have ?

I may have more questions but for the moment please answer each of the above.

Thx for responding. Answers to your questions are as follows:

  • I accepted the certificate
  • When I installed the editor, I was not asked about creating firewall rules
  • No drivers were offered during installation
  • Using a public library WiFi network
  • I use Webroot

The last two items may be your issue.

Public WiFi networks can be filtered and some services disabled.

May be worth disable webroot for a test and if that is the issue then add the create folders and create itself to the exclusions in webroot.

Add the Arduino directories to your antivirus / anti malware / other security exclusions.

So that would be at least two of the following for the desktop IDE

C:\Program Files (x86)\Arduino C:\Users\yourname\AppData\Local\Arduino15 depends on IDE C:\Users\yourname\AppData\Roaming\Arduino15 depends on IDE

If you have your sketches set up in a different location it’s also worth adding that directory to the exclusions also.

Additionally if you also use the online IDE “CREATE” the following directories.

C:\Users\yourname\AppData\Roaming\ArduinoCreateAgent C:\Users\yourname\AppData.arduino-create

If you have installed to a different drive swap the drive letter as needed. If you also have an unzipped IDE installed that path should also be added to exclusions.

I think it may have been Webroot. Within Webroot's settings, I selected "allow active process" for the Arduino plugin. This allowed me to successfully open the Arduino Web Editor, and create and verify sketches.

I don't yet have my Arduino board, so I now get an error message saying "No Plugin Connection. Uploading is disabled until you reconnect"... but I'm guessing this is because I do not yet have my board.

My board is scheduled to arrive tomorrow - hopefully everything will work 100% when I connect it to my laptop. I'll report back on how things go.

Thanks for your help to this point - much appreciated.

@Mistral101 if you are getting the message “No Plugin Connection. Uploading is disabled until you reconnect” it means that the browser is not communicating with the plugin, so having a board won’t fix the issue (sorry!).

I guess as @ballscrewbob suggested the issue is in Webroot. Please follow the directions given in the previous post and let us know how it goes.

Thanks!

I disabled Webroot, and I now no longer get the error message above.

However I am still not able to upload any sketches. In the dropdown selection for board/port, it asks to select both a board and a port. There is only a selection for my board - the Arduino 101 - and no selection for a port.

This dropdown says "Select both a Board and a Port if you want to upload a sketch. If you only select a Board you will be able just to compile, but not to upload your sketch" - but there is no option for me to select both the Arduino 101 board, and a USB port I am using to connect to the 101.

Any ideas on what to do from here?

The port is listed as a COM port not a USB port.

In windows look it up in device manager under "Ports (COM & LPT) may be hidden under win 10 so you might have to enable “show hidden devices”

A true Arduino will show up as COM x (x being the port)
Anything else is usually a clone but should still show up there if you have the correct drivers installed.

Given the trouble I was having with the online editor, I installed the Arduino Software. For some reason this took several hours and multiple attempts to download, but eventually installed successfully.

Once this software was installed, I checked back to the online editor, and now my Arduino Board was now showing up successfully on Com port 3.

I’m now using the online editor successfully. The only issue that sometimes occurs is that when using the “Monitor” window to see messages printed to the Serial port, the window sometimes gets grayed out with a message saying “Serial port unavailable”. This is a sporadic problem and hasn’t been too big of a deal so far. Maybe a question for a future post…

Once everything with my board and online editor was up and running OK, I reactivated Webroot, and so far have had no issues.

Took a while, but everything seems to be working sufficiently OK for now.

Thx for everyone’s help.

@Mistral

You are most welcome. It is still worth adding CREATE to webroots exclusions as that may help a little with your serial issue and overall speed of CREATE. But given that its a public WiFi you may occasionally suffer bandwidth dropout issues that would also cause a similar issue.