Not able to upload any sketches now

I posted this in another forum section before I saw the arduino 101 section !

Hello I just signed up to this forum and have read several threads with no solution to this problem that many others are experiencing. I bought an arduino/genuino 101 sparkfun kit from buyapi.ca Things were going fine and I managed to do all of the sample projects from the sparkfun site. After trying a few sketches on my own I can no longer upload any sketches at all. The board shows up as Arduino 101 Serial Monitor (COM3) in windows devices. Shows the same in device manager under ports. I can read the board info but every time I attempt to upload any sketch now, it compiles then fails.

Running Windows 7 ultimate 64 bit with Arduino 1.6.11 I get the following output

processing.app.debug.RunnerException at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:159) at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78) at processing.app.Sketch.upload(Sketch.java:1187) at processing.app.Sketch.exportApplet(Sketch.java:1160) at processing.app.Sketch.exportApplet(Sketch.java:1132) at processing.app.Editor$DefaultExportHandler.run(Editor.java:2409) at java.lang.Thread.run(Thread.java:745) Caused by: processing.app.SerialException: Error touching serial port 'com3'. at processing.app.Serial.touchForCDCReset(Serial.java:87) at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:143) ... 6 more Caused by: jssc.SerialPortException: Port name -com3 ; Method name - openPort(); Exception type - Port not found. at jssc.SerialPort.openPort(SerialPort.java:167) at processing.app.Serial.touchForCDCReset(Serial.java:81) ... 7 more

Tried on my laptop that has Windows 10 Home 64 but I get

Starting download script... Flashing is taking longer than expected Try pressing the MASTER_RESET button Error: Device is not responding Error: Device is not responding

I've already tried different cables on both computers and get the same result. Tried pressing MasterReset and Reset at various times no change.

Tried updating drivers on both computers but windows says the best driver is already selected.

Hoping that the board is not broken already and there is possible something else to try.

I had similar issues and was about to give up on the board.

First stop: Try the latest Curie 1.0.7 and the UI version 1.6.12

Second stop (definitely a "worked for me" answer with no real understanding): With 1.0.6 and 1.6.x I got master reset all the time, and at one point my board seemed entirely "locked" from sketch uploads.

I found a "magic combination" that unlocked it which was to try the sketch upload then hit master-reset/reset/master-reset and then the upload from the UI again all in fast succession... no idea why that worked but it seemed to do the trick.

Also found that if the UI calls for Master reset hit it while the upload is still trying.

After that experience I always heed code warnings on verify before trying the upload (since a sketch with warnings appeared to cause the situation in the first place for me).

All that said, the latest releases seem a lot more stable with the 101 board (EEPROM works thanks to Martino and I haven't see the "master reset" prompt since updating.

regs /z

I found a “fix” that works for me every time. Go to Device Manager, look for “Ports (Com & LPT)” and under that find the Arduino 101 Serial Monitor COM port. Right-click and select Disable. Once it is disabled, right-click it again and select Enable. When you get back to the Arduino IDE make sure the Board and Port (Tools menu) are still set for the Arduino 101. They usually are. Then try to Run your program again. Occasionally I also have to stop and restart the IDE after resetting the COM port, but these steps do work well for me when I start getting the messages mentioned.

Thanks for the idea but no dice for me. I don't get past the error at all and it just shows uploading after that but fails to actually upload. Already tried uninstalling IDE and java then reinstalling as well as the reset ideas.

Update: I uninstalled IDE 1.6.11 from my win 10 laptop including deleting the arduino15 directory then installed IDE 1.6.12 with curie 1.0.7 and after a few tries was able to upload on the laptop only. I am still unable to upload on my win 7 desktop and it appears that the reset does not even get sent to the board as LED13 just kept blinking.

It took a bit of research but here is what fixed it for me.

take note about the Antivirus as it may not just be AVAST.

I have been having the same problem on Windows 10 with both a Genuino 101 and a CurieNano.

I have sent back the Genuino 101 through vendor. DFRobotics don't seem as friendly.

I tried two different computers, all USB ports on each computer, different versions of IDE, different versions of Curie core.

I note some people report they get joy with USB2 but not USB3 then others vice versa so there seems no rhyme or reason.

I have event tried different versions of dfu-util from the dfu-util home page.

In desperation I have turned on error messages in the go arduino101loader and rebuilt it.

I tried forcing the dfu-util to look on specific usb port with -p.

I also noted that the dfu -d or --device codes in the go source differed slightly with my CurieNano so I tried changing that.

No way is either computer with any combinition of PC, IDE version, Core version, USB type, dfu-util version uploading.

Running dfu-util (0.9) from command line, -l finds no devices. -e reports no devices to detach (as a cross check).

I have wasted 3 weeks so I have now thrown the CurieNano in the bin and given it up as a joke.

As far as the USB side of things there is more than enough documented evidence had you taken time to search a little. The reason that aspect seems random is because there are so many factors involved all of which you would have been aware of with a little reading.

Quick outline is

  1. "Chipset used" There are a lot of vendors of USB 3.0 chipsets.

  2. "Ages of chipset" As chipsets are developed and updates even slight changes from the vendor could result in a a working chipset not working on some peripherals.

  3. "USB 3.0 speeds" not all chipsets and vendors are created equal in this respect and some rely on other components sub systems on a motherboard to make up the differences.

  4. Arduinos are not designed as such to work at or on USB 3.0 speeds but depend more on the supposed compatibility of USB which is supposed to have "backward compatibility to USB 2.0 (see 1. 2. 3. above)

I wish I had known you were going to throw good stuff away I would have at least paid the postage to benefit from your anger.