Not able to upload the program using usb

Hello all,
So i have been trying to upload program using the usb but its not working for me. It shows the following error.

Arduino: 1.8.8 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 3302 bytes (10%) of program storage space. Maximum is 32256 bytes.
Global variables use 366 bytes (17%) of dynamic memory, leaving 1682 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

What could be the possible reason for this?
I am able to download code to the arduino using progisp 1.72 with the below fuse:

LOW VALUE - FF
HIGH VALUE - D9
EXT. VALUE - FD

Did you used ISP for programming? Then, the bootloader is gone. In such case you need to load the bootloader first.

To expand on that - if you uploaded code with an isp programmer, that will erase the bootloader, and you wont be able to upload via usb anymore. To fix, connect the isp programmer to board like you did before, select the programmer and board from tools menu, and do burn bootloader. After that usb uploads should work again

Hello,

In tools, it what should i select? The isp programmer that I am using, it is of a local purchase and that name is not given in the programmer list. How should i proceed further?

You can use ProgISP if it works for you. The bootloader for UNO is ..\hardware\arduino\avr\bootloaders\optiboot\optiboot_atmega328.hex
adn fuse settings is in boards.txt.

Please tell us what the writing says on the largest black chip on the circuit board of your programmer. We can probably identify it from that information alone.

I've found that error to mean you've selected the wrong board type. It's probably not a Arduino/Genuino Uno.

I'm having the same problem, I tried to reload the bootloader and I get this message below. This is a new board and I have never uploaded anything. There is 1 steady red light , and 1 flashing red light and a green light that flashes real quick about every 30 secs.

Arduino: 1.8.8 (Windows 10), Board: "Arduino Nano, ATmega328P"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x39
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x39
Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

This is a new board and I have never uploaded anything.

Nano has 2 versions of bootloader: old for 57600baud and new for 115200baud. This is frequent problem if incorrect one is chosen.
However, you wrote you tried to reload the bootloader. Make sure you've selected correct bootloader. I'm recommending to use the optiboot. It is same as for UNO, needs less memory - 512b and it is for 115200baud.

Budvar10, I used the optiboot bootloader and changed the baud rate to 115200 and I am still getting this message. On the tools tab in Arduino 1.8.8 what should the Arduino: 1.8.8 (Windows 10), Board: "Optiboot Xplained Mini 328pb"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x24
Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
programmer option be set to? Mine is Arduino as ISP

Lets try this again

Budvar10, I used the optiboot bootloader and changed the baud rate to 115200 and I am still getting this message. On the tools tab in Arduino 1.8.8 what should the Arduino: 1.8.8, Mine is Arduino as ISP

(Windows 10), Board: "Optiboot Xplained Mini 328pb"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x24
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x24
Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
programmer option be set to?

Why did you change the board from "Arduino Nano, ATmega328P" to "Optiboot Xplained Mini 328pb"?

Which board are you using?

Triton28:
I tried to reload the bootloader

Was the process successful, or did it fail? If it was successful, what was the exact Tools > Board and any other custom Tools menu selections you used when burning the bootloader?

Triton28:
programmer option be set to? Mine is Arduino as ISP

When you are doing a regular upload, the Tools > Programmer selection makes no difference. The only time that matters when you do Sketch > Upload Using Programmer or Tools > Burn Bootlaoder.

I got this from the optiboot website and thought that was what they were saying to do. I changed it back to Arduino Nano and it still get an error. Since I installed optiboot is that was it is using as a bootloader? I don't see an option to change or select which bootloader to use

To burn Optiboot onto an Arduino board

Select the appropriate Optiboot board type (or non-Optiboot if you want to change back)
Connect your Arduino to an ISP programmer [[Installing]]
Use the 'Burn Bootloader' item in Arduino.
You can then upload sketches as normal, using the Optiboot board type.

Please answer the questions I asked in my last reply. The sooner you do that, the sooner you're going to get help with your problem.

Sorry missed it. It is Arduino Nano Atmega 328P CH340 on Com 3
Thanks for your patients!

Please try this:

  • Tools > Board > Arduino Nano
  • Tools > Processor > ATmega328P (Old Bootloader)

Now try uploading again.

If that doesn’t work, then answer the other questions I asked.

I downloaded theCH340SER.exe drivers for clones for my Windows 10 x64 , still no luck

Tried the old bootloader and nothing

Arduino: 1.8.8 (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x70
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x70
Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

For the fourth time, I'm going to request that you answer these questions:

You said:

Triton28:
I tried to reload the bootloader

Now here are my two questions:

  • Was the Burn Bootloader process successful, or did it fail?
  • If the Burn Bootloader process was successful, what was the exact Tools > Board and any other custom Tools menu selections you used when burning the bootloader?

It's very difficult to help you if you won't answer my questions! If you don't understand the question, then explain what's confusing and I'll try to reword it. If you don't remember the answer, then just say so.

Now here are my two questions:

Was the Burn Bootloader process successful, or did it fail?
It failed, it has not been successful loading anything I have done since I started

If the Burn Bootloader process was successful, what was the exact Tools > Board and any other custom Tools menu selections you used when burning the bootloader?I
It was not succesful, I installed optiboot like you suggested but I don't know if it is using optiboot because it just says burn bootloader and then is starts.

Here are my settings in Arduino 1.8.8
Board "Arduino Nano"
Proccessor "Atmega 328p"
Port "Com3"
Programmer "Arduino as Isp

I know the baud rate on com3 in device manager is set at 115200