Not blinking with 1 sec delay but more - ATMEGA 16 L 8PU

I am using arduino as programmer with Atmega 16L 8PU. I have successful uploaded the blink program in the mcu, but the delay is 10 times than it is supposed to be.

I have tried to use 16 mhz ext clock but still not getting results.

Please solve this problem.

Thanks in advance.

Did you change the fuses?

I have used the following 3 files. I did not change any settings with the fuses in the boards.txt file.

I didnt use http://www.engbedded.com/fusecalc/ site to get the fuse settings.

Please check the files attached.

If I have to change the fuse somewhere else then let me know.

Blinkmega16.ino (908 Bytes)

pins_arduino.h (4.33 KB)

boards.txt (26.5 KB)

Abhijit_Pal:
If I have to change the fuse somewhere else then let me know.

Well, on the processor. That is where it counts.

I am hoping that some of you people will know exactly what to change…

Abhijit_Pal:
SORRY BUT THE ABOVE POST IS USELESS TO ME. NO OFFENCE.

Shouting may get you help. But I doubt it. It certainly will not get me to help you. (Well, actually, this post is probably helpful. So I lied.)

A better choice would be to simply state that you don’t understand my post. Something along the lines of “I don’t understand” seems reasonable. Following that with a list of things you have tried would certainly be beneficial.

An even better choice would be for you to spend a few minutes with Google. Then, if that does not bring clarity, ask for assistance. This should get you started…

https://www.google.com/search?q=change+avr+processor+fuses
https://www.google.com/search?q=change+fuses+site:forum.arduino.cc

I can probably try to explain why did I say what I said… but it wont change so many things…

SORRY GUYS, ITS Still the same..... LOL.

Burn bootloader/fuse >:(

The next step is to burn the bootloader or/and fuses. For most cores, you don’t need to use the bootloader. :slight_smile:

My Arduino extra core doesn’t need any bootloader, but only needs some fuses to be set. :smiley:

You can burn the bootloader and/or the fuses, by selecting Tools -> Burn Bootloader. Make sure you have chosen the correct board type before you do that. :stuck_out_tongue: