not in sync again?

Hi everyone,

I burned new bootloader with ISP (anyone interested in the whole story it is here: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1266442764 ), but now I still get the

Binary sketch size: 1514 bytes (of a 126976 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

when I try programming it with another version of blink :frowning:

I even deleted settings and then choose Arduino MEGA as board and Port 5 which is the correct board.

When I press upload and the program is compiled L13 flashes faster couple of times than Rx flases 3 times and then L13 starts flashig at the same old 100ON1000OFF again.

I can’t figure this one out guys, does anyone have any idea? I am super new to this, with some background in programming and electronics, but no history with uControllers. Is it possible I killed the USB2Serial chip with static maybe? If anyone has any idea, please tell me I’ll try anything…

You might try editing the upload baud rate for the Mega in the boards.txt file (in hardware/arduino in the Arduino application directory). I'm not sure why the bootloader would be running at the wrong speed, but it's possible.

I am experiencing this same issue for the 1st time. I have the atmega328 chip with Arduino Duemilanove USB. Running on Win Vista, I tried arduino 13,17 and 18. My bias is leaning toward a windows vista-update bug that messed up the com-port/RS232 driver functionality. Reinstalled FTDI drivers, from the FTDI website, from what's included with arduino environment, and I even let windows install them > but neither option solved the problem.

Going to try this on a windows XP computer at work tomarrow: If I still have the issue then it must be a problem with my 328 :0(

PS: What are nominal baud rates for the atmega 328 for bootloading? Here were my defaults:

atmega328.upload.protocol=stk500 atmega328.upload.maximum_size=30720 atmega328.upload.speed=57600

atmega328.bootloader.low_fuses=0xFF atmega328.bootloader.high_fuses=0xDA atmega328.bootloader.extended_fuses=0x05 atmega328.bootloader.path=atmega atmega328.bootloader.file=ATmegaBOOT_168_atmega328.hex atmega328.bootloader.unlock_bits=0x3F atmega328.bootloader.lock_bits=0x0F

atmega328.build.mcu=atmega328p atmega328.build.f_cpu=16000000L atmega328.build.core=arduino