not in sync: resp=0x33

Hello All,

Every time I try to upload any code from the GUI to my board (UNO) I get the error :avrdude: stk500_getsync(): not in sync: resp=0x33. I am using Windows XP, and as I said above the UNO board. As far as I know I have my drivers installed correctly and such. I was able to get my code uploaded a while back, and everything seemed to work fine, but then I didn't touch the board in a while and come back to it and I get this error. I've searched all over the web and cannot find anyone with the same error, wondering if anyone has any ideas?

Thanks in advance Tom



Thank you for the advice, I tried the loop back tests which it passes. Tried two different usb cables, 3 different usb ports on the computer but to no avail.

any other suggestions? I am just puzzled why it worked just a few weeks ago and now I come back and its being goofy on me.

Another thought, I am trying to check to see if the bootloader is on the uno. after the uno is powered up I press the reset button and the "L" led does not blink. Am I supposed to hold it down. I have tried both and it still does not blink. Could this be my problem and if so what steps should I do to correct it