Not really sure

Well I’ve been having installation problems, and I’m not really sure what happened.

I just got my new arduino mega and plugged it in, I was following the installation guide and when the setup wizard came up it said " Install the software automatically (Recommended) " and when I got to that point in the guide it states something along the lines of " to the best of its efforts it wont be able to find the driver and fail " so I decided to run it to see if it would, well to the best of its efforts it did find a driver it found suitable. Now every time i plug it in, uninstall it and remove it, it automatically installs the same driver. and i tried following the usb to ftdi conversion driver over it and the arduino uno driver and select that to install over the usb serial port. but doesn’t appear to work.

anyway i use windows XP and im not sure if thats actually what is happening but seems to be.

here is how it appears in my device manager as of now

arduino device manager.jpg


Help us help you :)

What model of Arduino Mega are you using? (having the serial number also helps) this will help us understand what driver you actually need. What version of Arduino?

Are you able to upload at all?


I have an Arduino Mega-ATmega1280

and no I'm not able to upload at all.

the D2XX drivers are not the right ones

you should use the ones that come with arduino (in the “drivers” folder)

I recommend you remove the current drivers through device manager then
you re-install the ones that are inside the arduino folder.


I would but windows keeps self installing its own driver and when i plug the arduino in, it comes up as USB Serial Port(COM5) instead of arduino mega or uno. so i just try update the driver to select the arduino driver folder and it says " The wizard could not find a better match for your hardware than the software you already have installed. "

but i have tried to write to the arduino with com 5 and this pops up.

Problem uploading to board. see for suggestions.

Binary sketch size: 1584 bytes (of a 126976 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

And this is with windows XP SP 3 with "Never search Windows Update for drivers. " under hardware of my computer

If you have an old Arduino Mega, that doesn't show up as Arduino Mega in the device manager. it will show up as a generic usb serial port

You should remove the driver then follow these instructions: On Windows XP, the Add New Hardware wizard will open:

When asked Can Windows connect to Windows Update to search for software? select No, not this time. Click next. Select Install from a list or specified location (Advanced) and click next. Make sure that Search for the best driver in these locations is checked; uncheck Search removable media; check Include this location in the search and browse to the drivers/FTDI USB Drivers directory of the Arduino distribution. (The latest version of the drivers can be found on the FTDI website.) Click next. The wizard will search for the driver and then tell you that a "USB Serial Converter" was found. Click finish. The new hardware wizard will appear again. Go through the same steps and select the same options and location to search. This time, a "USB Serial Port" will be found.

Is it a new board? did you try it on a different computer? if you give me the serial number i can lookup when it was made etc.


the serial number is MO19147 i believe

i have a usb serial converter and the usb serial port that self installs on plug in which gives me no options on where to direct where it gets these drivers from so im not sure if they're the correct ones.

i tried uninstalling and then using the " Add new hardware wizard " get to the first window and gives me no options except next or cancel, so i press next, it searched for hardware and installs what ever it finds, which im not sure if it is the correct drivers or not. assuming it isnt the correct software because i try to upload to the board using COM(5) the usb serial port and COM(1) communications port labeled as such in device manager. which gives me the

Binary sketch size: 1584 bytes (of a 126976 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


and i got the board in a package im assuming its an older board.