Not uploading, thought it says it has.

Alright, I just picked up an Arduino board and am having some issues getting it programmed. I checked through the forum a bit, but couldn't exactly find my problem. Sorry if this is a repost.

I wrote a very simple program that simply turns the LED on. That's all. However, no matter what I upload I it just keeps playing the "LED 13 stays off and then blinks 3 times every couple seconds or so" program. I've tried reseting it, uploading at different times after resets, etc etc.

What's strange is that Arduino 0008 tells me that the program has compiled and uploaded. I even see the flashing Tx and Rx led's on the board blinking.

Suggestions? I'm on a Macbook Intel 1.83 duocore, OS 10.4.10, with the newest drivers.

Do you have the right microcontroller selected in the Tools > Microcontroller menu? It should match the name of the chip on your board. Do you have anything connected to the board?

Yes, it is set correctly as the Atmega168. I have the newest board. I believe the correct USB driver is set as well.

Even though it's probably not the problem, can you post the code you're trying to upload? What messages do you get in the environment when you try to upload?

Is there anything connected to the Arduino board? Is it sitting on a conductive surface?

Anyone else have any good ideas? This problem tends to baffle me.

Yeah, I realize that it's pretty vague, I wish I could be more helpful. I just tried it again using the Windows software, but no luck.

I tried this time just loading the blink program which comes included. It should keep the LED on for 1 second, and off for one second. Nothing, just the same, 3 blinks followed by several seconds (it's really irritating how it keeps taunting me).

This is my result in the debug window:

Binary sketch size: 1108 bytes (of a 14336 byte maximum)

Atmel AVR ATmega168 is found. Uploading: flash Firmware Version: 1.15 Firmware Version: 1.15

And then the status bar says "Done Uploading." Like I said, the Rx and Tx lights blink quickly during the upload.

You might try selecting ATmega8 from the Tools > Microcontroller menu and then switching back to ATmega168. That should recompile some libraries - I suppose it's possible you somehow had ATmega8 versions of them.

On the other hand, maybe it's just a problem with the LED. Try uploading the Graph example or something else that just sends data back to the computer. See if you can see it in the serial monitor.

I have the same problem with the mini.

Downloading works fine for a while. Then, all of a sudden it stops, and the prior program continues to run, even though the mini claims to have downloaded the new program.

Is it possible that "hot swapping" it is frying the boot loader but not the prior downloaded program? Seemed to work great for a long bit. Of course, 2 out of 3 of my mini's now won't download ... maybe it's related ...

What I mean by "hot swap": I've been rather brutal on the poor beast ... leaving the battery connected to my device breadboard, and usb cable connected to the usb breadboard, I tear the arduino from the device bread board, and slam it into the usb breadboard, laughing manically all the while.

It's possible. My best guess is that the problem is caused by low power supply voltages (since the boards don't have brown-out detection enabled). This could show up if you rip the board out of a circuit, I suppose. Sorry I don't have a better answer for you.

I ended up just exchanging my board. Worked perfectly, first try.

Given that it worked for a long time, and failed only after "rugged" treatment, don't think asking for a replacement would be fair. At least, not unless the arduino folks say that it supports yanking the chip out and jamming it in while power is supplied. Especially given the warning about the mini's lack of resilience to power issues ... I think the thing for me to try next is downloading a new bootloader.

Yeah, this was my first experience with the Arduino, so I don't have any qualms about sending it back.

I love it, though. Fantastic device.

I have the same problem with mine. The NG board has worked beautifully for months. Then today I find out that uploading doesn't work suddenly. The symptom is exactly same with above posts. Any solutions?

Done uploading. Binary skethc size: 1108 bytes (of a 14336 byte maximum)

Atmel AVR ATmega168 is found. Uploading: flash Firmware Version: 1.15 Firmware Version: 1.15