Nothing works with arduino UNO wifi

Hello

I want to make a very basic program with arduino UNO wifi board.

I have first download and install “WiFi Link” library.
If i just include #include <WiFiLink.h> i got this error:

Libraries/WiFi_Link/src/utility/comm.h:41:8: error: ‘CommDrv’ does not name a type

I have also tried UnoWiFiDevEd library. The samples compiles but there is nothing to set ssid and password.

I have tried to call undocumented Wifi.connect(ssid,pass) but it freezes and i have no error code (the function is void!)

Thanks

which wifi board?

Uno Wifi is an arduino.org product. with the default firmware in ESP, use UNOWiFiDev.Edition library for network access

Juraj:
Uno Wifi is an arduino.org product. with the default firmware in ESP, use UNOWiFiDev.Edition library for network access

This is arduino.cc not arduino.org

Did you read Arduino - Home? The Web Panel Tab?
Uno WiFi has a 'firmware' in the WiFi chip ESP 8266. WiFi connection is managed there. You do not need initialize WiFi in your sketch.

Juraj: Thanks but what will happen if i configure this way a connexion to my hotspot and then if this hotspot is off or have a problem ? How wifi.begin() will detect a failure ?

Thanks

Hi I also have the same problem I have the uno wifi. I updated the firmware for WiFi Link firmware. This seemed to work but nothing seems to work.

when running

http://www.arduino.org/learning/tutorials/boards-tutorials/connectwithwpa-unowifi

this example, i get the follwing issues:

/Users/benthompson/Documents/Arduino/libraries/WiFi_Link/src/utility/wifi_drv.cpp: In static member function 'static uint8_t WiFiDrv::getEncTypeNetowrks(uint8_t)':
/Users/benthompson/Documents/Arduino/libraries/WiFi_Link/src/utility/wifi_drv.cpp:453:10: warning: converting to non-pointer type 'uint8_t {aka unsigned char}' from NULL [-Wconversion-null]
return NULL;
^
/Users/benthompson/Documents/Arduino/libraries/WiFi_Link/src/utility/wifi_drv.cpp: In static member function 'static int32_t WiFiDrv::getRSSINetoworks(uint8_t)':
/Users/benthompson/Documents/Arduino/libraries/WiFi_Link/src/utility/wifi_drv.cpp:478:10: warning: converting to non-pointer type 'int32_t {aka long int}' from NULL [-Wconversion-null]
return NULL;
^
Sketch uses 7100 bytes (22%) of program storage space. Maximum is 32256 bytes.
Global variables use 858 bytes (41%) of dynamic memory, leaving 1190 bytes for local variables. Maximum is 2048 bytes.

I am running IDE 1.8.3

Could anyone point me in the right direction please! I am truely lost here..Many thanks in advance.

bcthompson:
Hi I also have the same problem I have the uno wifi.

You can't read? ? ?

This product is designed by a different company.
Go there and ask your questions.

SHEESH.

I have bought this board on THIS website

testpresta2:
I have bought this board on THIS website

You're confused.

bcthompson, those are just warnings. I use WiFi link firmware, and it works.

testpresta2, I don't now how you can test the connection state, I changed firmware to WiFi Link.

Juraj: When i run my program, i want to access to my arduino program with http, i am seeing ESP administration page...

testpresta2, study the UNOWiFiDev WebServer example

bcthompson, we continue on arduino.org

Juraj, this is exactly what i've done...and it displays me the administration page...

if you in the browser enter url
http:///arduino/webserver/
it shows the firmware web panel?
try different browsers. the returned http header and html body are too simple for some browser

Thanks

Do you know if there is a way to disable this firmware web panel or protect it by a password ?

Thanks

It's 'Developer edition'. The original firmware of Uno Wifi Dev Ed is an older fork of jeelabs esp-link. This fork is discontinued.

arduino.org develops a new firmware for boards with built-in esp8266 (Primo, Starr Oto and Uno WiFi standard edition). It's called WiFi Link. With WiFi Link the web panel stops if you start a webserver on standard port in your sketch.

It's possible to change the firmware of Uno WiFi Dev Ed to WiFi Link firmware or to JeeLabs esp-link firmware. With installed firmware you must use it's Arduino sketch library, because the library is just a proxy to functions on the esp side.

Sketch OTA upload doesn't work with jeelabs esp-link on Uno Wifi for now.
With WiFi Link firmware ota upload works for now just if you build it from the source code of the ota branch.

I use the WiFi Link firmware.

ieee488:
You're confused.

https://store.arduino.cc/arduino-uno-wifi

Juraj:
https://store.arduino.cc/arduino-uno-wifi

Currently sold out

Hmmmmmmm Amazing how the OP is able to buy something that is sold out

whereas
http://www.arduino.org/products/boards/arduino-uno-wifi
isn't sold out