nRF24L01 2.4GHz probleme

Bonjour à tous,

Voila j’essaye de programmer un petit essaie pour faire fonctionner mes deux nRF24L01 2.4GHz .
Apparemment la réception ce fait bien… puisque selon mon code il ne me marque pas “No radio available”

Mais bien mes print…

Par contre je n’arrive pas a envoyer et réceptionner mes données…

Voici le code de mon emetteur :

#include <SPI.h>
#include <nRF24L01.h>
#include <RF24.h>

#define CE_PIN   9
#define CSN_PIN 10

const uint64_t pipe = 0xE8E8F0F0E1LL;

RF24 radio(CE_PIN, CSN_PIN); // Create a Radio
int Roue[2];  

void setup ()
{
  radio.begin();
  radio.openWritingPipe(pipe);

  Serial.begin (9600); // 9600 bps
}
void loop ()
{
  Roue[0] = 3;
  Roue[1] = 5;
  radio.stopListening();
  radio.write(Roue, sizeof(Roue));
  radio.startListening();
}

Et voici le code de mon recepteur :

#include <SPI.h>
#include <nRF24L01.h>
#include <RF24.h>

#define CE_PIN   9
#define CSN_PIN 10

const uint64_t pipe = 0xE8E8F0F0E1LL; // Define the transmit pipe

/*-----( Declare objects )-----*/
RF24 radio(CE_PIN, CSN_PIN); // Create a Radio
/*-----( Declare Variables )-----*/
int Roue[2];  // 2 element array holding Joystick readings

void setup()   /****** SETUP: RUNS ONCE ******/
{
  Serial.begin(9600);
  delay(1000);
  Serial.println("Nrf24L01 Receiver Starting");
  radio.begin();
  radio.openReadingPipe(1,pipe);
  radio.startListening();;
}//--(end setup )---


void loop()   /****** LOOP: RUNS CONSTANTLY ******/
{
  if ( radio.available() )
  {
    // Read the data payload until we've received everything
    bool done = false;
    while (!done)
    {
      // Fetch the data payload
      done = radio.read( Roue, sizeof(Roue) );
      Serial.print("roue gauche = ");
      Serial.println(Roue[0]);
      Serial.print(" Roue droite = ");      
      Serial.println(Roue[1]);
      
      
      delay(20);
    }
  }
  else
  {    
      Serial.println("No radio available");
  }
}

Au niveau des branchements ils sont fait comme sur le site

https://arduino-info.wikispaces.com/Nrf24L01-2.4GHz-HowTo

Voila pouvez vous m’aider?

Merci à tous :slight_smile:

Est ce mon code? ou bien ai je des modules defectueux? :frowning:

Si je n'ai pas de réponse... je suppose que mon code d'essai est correct mais que c'est mon materiel qui doit être défectueux :(