NRF24l01 not working with nano

So I’ve successfully connected them in normal breadboard using uno, but then I moved it to the pcb using nano that I designed, it does not work.
I tried this code and they all output 0:

// 18 Mar 2018 - simple program to verify connection between Arduino
// and nRF24L01+
// This program does NOT attempt any communication with another nRF24

#include <SPI.h>
#include <nRF24L01.h>
#include <RF24.h>

#include <printf.h>

#define CE_PIN 9
#define CSN_PIN 10

const byte thisSlaveAddress[5] = {‘R’,‘x’,‘A’,‘A’,‘A’};

RF24 radio(CE_PIN, CSN_PIN);

char dataReceived[10]; // this must match dataToSend in the TX
bool newData = false;

void setup() {
Serial.begin(9600);
printf_begin();

Serial.println(“CheckConnection Starting”);
Serial.println();
Serial.println(“FIRST WITH THE DEFAULT ADDRESSES after power on”);
Serial.println(" Note that RF24 does NOT reset when Arduino resets - only when power is removed");
Serial.println(" If the numbers are mostly 0x00 or 0xff it means that the Arduino is not");
Serial.println(" communicating with the nRF24");
Serial.println();
radio.begin();
radio.printDetails();
Serial.println();
Serial.println();
Serial.println(“AND NOW WITH ADDRESS AAAxR 0x41 41 41 78 52 ON P1”);
Serial.println(" and 250KBPS data rate");
Serial.println();
radio.openReadingPipe(1, thisSlaveAddress);
radio.setDataRate( RF24_250KBPS );
radio.printDetails();
Serial.println();
Serial.println();
}

So I used multimeter to test the connection on PCB and it seems everything is connected. The power is supplied is steady at 3.3V, and there’s correct connection everywhere. But the only strange thing is I connected D8 with CS, D7 with CE on my PCB, but if I check, there is connection between CS to pin D8,D9.D10 and there’s connection between CE on D8. D9 and D10 as well. I checked my pcb and the traces are correct, there is no trace connected do D9 and D10, I wonder if this is normal?
I plan to add capacitor between ground and power source on the nrf24l01, so is there any other suggestion? Thank you!

You could share the schematic, the layout and photos of the module/pcb.

Looks as if there is a short between D8 D9 and D10.

It seems (from info in other Threads) that a nano cannot provide enough 3.3v current for an nRF24.

If you suspect that is the problem try powering the nRF24 with a pair of AA alkaline cells (3v) with the battery GND connected to the Arduino GND.

...R
Simple nRF24L01+ Tutorial

Whandall:
You could share the schematic, the layout and photos of the module/pcb.

Looks as if there is a short between D8 D9 and D10.

I tested the connection on the working version of the uno and it's the same, there's continuity between CE and CSN on the UNO version as well.

I have no details of the power ar any connection.

I did never check continuity between CE and CSN.

OP: give detailed information or whine alone.

My connection on PCB was correct, I don't know why it doesn't work, but I soldered new nano, new components, new rf24l01 into new pcb and now it works, not sure why the old one doesn't work even though I attached capacitor in parallel.