nRF24L01+ using RF24 library problem

Hi,

I try to send a temperature and the voltage of a 3S LIPO with a nRF24L01+ but it didn’t work. It only receive something when I press the reset button on the TX arduino. I can see 2 massages and than he say: “No radio available”. Could somebody help me out?

My code is in the attachment.

Raoul.

Temp_meten.ino (1.32 KB)

TEST_TX.ino (2.12 KB)

Volt_Calc.ino (650 Bytes)

TEST_RX.ino (1.54 KB)

Temp_meten.ino and Volt_Calc.ino belong to TEST_TX.nio

your description is very vague

start off with telling what rf24 library you are using, there seem to be many different forks (I use tmrh20s fork as it seems to be stable and actively worked on)

if the arduino has a problem with the radio, i would suggest checking the hardware/connections first, and try to get that working using one of the supplied examples in the library also keep in mind that the nRF is a 3.3v device (but can be connected to a 5v arduino) and finally - the nRF has problems with noise on the power supply line - it is solved by soldering a condensator between vcc/gnd directly on the module. I had good results with a 10UF elco, others used all sorts of caps, with good results.

there is a lot of information that you can find about the arduino/nRF combination - google is your friend

my personal experience is that the nRF is a bit flaky to get working reliably. I am still struggling myself, to be honest

good luck!

Now I have tryed a other library the RadioHead library and copied the code from http://arduino-info.wikispaces.com/RadioLink-Joystick-To-Servos

and have done some adjustments so its measure the temperature and voltage and finally it works!