nrf24l01

Bonjour à tous

je fais appel à vous car je deviens chèvre.

j'essaie de faire communiquer 2x nrf24l01 montés sur des UNO

et je n'obtiens pas de communication. je ne pense pas que mes câblages soient erronés.
nrf uno
1 gnd gnd
2 VCC3.3 3.3V
3 CE 9
4 CSN 10
5 SCK 13
6 MOSI 11
7 MISO 12
8 IRQ nc

j'ai également montées les 4 résistances de 10K

j'utilise la lib "Mirf".

je voudrais repartir de zéro, mais avec tout ce que j'ai trouvé et lu sur le net, je ne sais plus par ou commencer ni à quoi me fier.

pouvez vous me donner un lien qui me permette d'avancer en toute confiance dans ce montage.

en attente de vous lire.

bonjour
tout chaud , à peine démoulé :grin:

Wouha............. :slight_smile:
merci, je vais m'y plonger et je vous tiens au courant

hélas, trois fois hélas, j’ai ping et pas de pong
j’ai vérifié 50 fois mes cablages et je ne détecte rien.

je vais commander une nouvelle paire de nr24l01…et je vous tiendrai au courant

merci Artouste

je viens de tester en croisant les prg sur les UNO

les deux émettent bien lorsqu'ils sont émetteurs puisque le prg affiche toutes les secondes "Ping... Pas de pong".

mais les deux restent sur "GO!" lorsqu'ils sont récepteurs.

il n'y a pas de liaison.

Il paraît que rajouter une petite capa entre le 3,3v et le GND des nrf améliore la réception/émission.

Dans une application pour laquelle j'utilisais deux nrf24l01+, sans capa sur breadboard ça marchais bien mais je les ai quand même rajoutées sur le montage final (4,7microfarad)

merci Jambe :slight_smile:

ta suggestion est concluante

des électrolitiques de 10µf et 6.8 µf entre les 3.3 et GND sur les deux platines et:

ping...pong: 1ms.

il est tard et je me remets la dessus demain avec une alim extérieure de 3.3V