Odd problem with 3.2" touchscreen

Hello all

I have a (now unavailable) 3.2" TFT touchscreen on a shield, attached to a Mega2560p
All been fine and dandy for about 18 months.

All of a sudden, it has started to fail to read the touchscreen.
Not a calibration issue, so I dismantled it to investigate.

Re-flowed all the solder joints etc. All seem fine.

The screen will not read the touchscreen (Using Utouch library).... unless you touch the T_CLK pin with your finger?
Then it reads fine.

Should add, its a TFT_320qvt screen if that helps

Tried holding it both high and low with a 10k. Also tried a 0.1uf cap.
No luck.... but instantly works again when you stick your pinky on it (and not as in... pressing to make a dodgy solder contact).

Any ideas?

So, after taking all the screen apart, checking all the connections, testing all the wiring.... and 2 whole evenings....

It's the crap Arduino IDE. Rolled the IDE back from 1.8.7 (or whatever it is now) to 1.5.7 and the damn thing works fine.

Even the updated URtouch library didn't fix it.

Oh yea.... that's why I gave up on Arduinos