Official M10 GSM Shield's Status led very faint/dim

Hello everyone,

I got myself the official GSM shield and played around with it a bit and I have two problems:

1)

At first the shield turned on just fine (ON/Status led were on, network led blinking).

I played with the shield around a bit yesterday and today the Status led is faint - When I connect Vin, grounds and 5V, the ON led shines brightly while the status led is on but is very very faint/dim.

I can't get the network led to blink by pressing the power button either.

Does anyone know why this happenes?

2)

While I know this is an Arduino forum, I'll still try here - I tried to interface with the GSM shield using a PIC microcontroller and have not managed to get ANY response on the "AT\r" command - No OK, nothing. I tried to apply different baud rates, using/not using a max232 to pull up the 3V output from the shield and using 2 transistors to pull it up as well. I never got anything. Am I missing something?

I'd appreciate it if anyone can chime in on this.

Thanks,
Inky

If you connected an AC/DC adapter or 5 volt and led was still faint, I think is a hardware problem.

Contact with Arduino Team to replace your shield.