Old Fart trying to get the Arduino UNO to work

Hi Guys, I'm trying not to panic. So I got my son a Arduino Uno Make:it robot bulldozer kit, he built it and now I found out Radio shack doesn't have any support files for it any more. And here I am a old fart trying to figure out how to use the Arduino UNO. I down loaded the arduino desktop IDE, that didn't work, So I down loaded arduino web IDE and that didn't work. So I'm trying to get the Arduino UNO to do something, but it will not communicate with my computer or my computer will not communicate with it (not sure which one). Can find both the device and the device driver/sketch on my computer, but they will not recognize each other. I copied and pasted two of the automatic responses below. I am running windows 10. This is the third day I have bin working on this, about 6hrs total. Please guyed me in right direction. Thanks -John

No Plugin Connection. Uploading is disabled until you reconnect. HELP

-- Select Board or Port --

SHARE sketch_feb10a.ino ReadMe.adoc

 1 2 3 4 5 6 7 8 9 10 11 12 /* */ void setup() {

} void loop() {

} Error compiling, check if you have selected a board and if it's currently available. Arduino: 1.8.1 (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 1192 bytes (3%) of program storage space. Maximum is 32256 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes. avrdude: ser_open(): can't open device "\.\COM1": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

Another old fart here…

Couple of quick pointers.
Use CODE tags ( </> ) when posting code or error messages as it makes it easier for anyone looking at things for you.

Go into the PREFERENCES in the IDE and turn on VERBOSE as shown at the bottom of your post. and that output could be quite useful to others trying to help.

Now onto some of the easier things you can try.
Windows 8.0 / 8.1 suffer from high “driver enforcement” policy by default.
So google that and make sure the drivers are installed.
Also if its from Radio shack it should be a legit board so we probably don’t need to worry about the drivers for clone boards.

Next is to double check what you can see in windows DEVICE MANGER under COM LPT PORTS.
Ignore COM 1 but you should have something under another COM number…If not you may have something with an exclamation mark that will be the Arduino but it may still have a driver issue.
Could take a couple of restarts and plug/unplug the board to get it to kick in.

One more thing AVOID USB 3.0 ports and stick with USB 2.0 for Arduino work. If you have to use USB 3.0 make sure you use a powered USB 2.0 hub between the computer and the Arduino.

Hi Bob, I think I turned on verbose, hope that helps, I was able to get the traffic light to work, yay!!!!! On sketch, in the category (tools), I believe it was board type, and I clicked on (UNO) or (arduino UNO)Wow, it worked, my first program. I am memorized by this thing. This is the test. Wow. But I need to get the Bulldozer working. I will insert the Bulldozer code at the bottom and error last. Any suggestion would be greatly appreciated. Thanks for letting me mumble on here. It gave me confidence to keep at it.

trafic_light pinMode (3, OUTPUT); pinMode (4, OUTPUT); pinMode (5, OUTPUT);

}

void loop() {

digitalWrite (redled, 1); delay(9000); digitalWrite (redled, 0); //stopped digitalWrite (yellowled, 1); delay (4000); // yellowled lights for 3 sec. digitalWrite (yellowled, 0); digitalWrite (greenled, 1); delay (12000); digitalWrite (greenled, 0);

} sketch_jan30c_IR_remote

}

void setup() { // put your setup code here, to run once:

}

void loop() { // put your main code here, to run repeatedly:

}static unsigned int valueo=0; //old remote control code static unsigned int valuen=0; //new remote control code valueo=bulldozer.remote_value_read(); //read code from remote control if (valuen!=valueo) //if the remote control code is different than the previous code, then change status { valueo=valuen; //refresh the previous code if(valueo==SW1) //SW1 action { bulldozer.bulldozer_head_up(0); //stop bulldozer blade bulldozer.go_forward(60); //go forward } else if(valueo==SW3) //SW3 action { bulldozer.bulldozer_head_up(0); //stop bulldozer blade bulldozer.go_backward(60); //go backward } else if(valueo==SW2) //SW2 action { bulldozer.bulldozer_head_up(0); //stop bulldozer head bulldozer.turn_front_left(60); //turn left } else if(valueo==SW4) //SW4 action { bulldozer.bulldozer_head_up(0); //stop bulldozer head bulldozer.turn_front_right(60); //turn right } else if(valueo==SW5) //SW5 action { bulldozer.move_stop(); //stop wheels bulldozer.bulldozer_head_up(60); //move bulldozer blade up } else if(valueo==SW6) //SW6 action { bulldozer.move_stop(); //stop wheels bulldozer.bulldozer_head_down(60); //move bulldozer blade down } else //if no buttons are pushed bulldozer.all_stop(); //stop all motors } } /*********************************************************************** * Remote Scan ************************************************************************/ ISR(PCINT0_vect) //interrupt code { bulldozer.remote_scan(); //analyze signal from RadioShack Robotics Remote Control

ERROR CODE?????>>>>>>>>>Arduino: 1.8.1 (Windows 10), Board: "Arduino/Genuino Uno"

sketch_jan30c_IR_remote:11: error: 'valueo' does not name a type

valueo=bulldozer.remote_value_read(); //read code from remote control

^

sketch_jan30c_IR_remote:12: error: expected unqualified-id before 'if'

if

^

exit status 1 'valueo' does not name a type

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

You have a 5 minute break to read this (its an anti spam feature on here)
So I am going to repeat this

Use CODE tags ( </> ) when posting code or error messages as it makes it easier for anyone looking at things for you.

Also going to send you here for the 5 minutes too.

You can edit you posts to do that if you wish as most hate to see code strewn around and the forum can strip bits out on occasion if not used inside the code tags. As you can see it inserted a smiley in your text.

Just like your new toy you should get used to the place a little as you might come back more than you think LOL…