OLD STORY: avrdude: stk500_getsync(): not in sync: resp=0x00

I have a problem with Arduino Atmega Nano with Atmel MEGA 328 after using Teensyduino 3.0.

The code doesn't want to upload. LEDs do stop blinking for a moment on the Arduino Nano, but than I get a message: avrdude: stk500_getsync(): not in sync: resp=0x00

What do I set in "Tools" menu to make it work?

Comport 3 or Comport 9?

What do I choose in "Programmer" menu?

USB menu grayed out ... When I tried to download new copy of Arduino software and run that, there was no USB menu. Is there any way I can make sure that Arduino compiler software doesn't access any folders that have old Teensy settings in them? Where do I find those files that tell new Arduino compiler installation what old settings were?

I installed FTDI drivers. How do I know where and why the USB is not working? This issue has nothing to do with the code I am writing to the Arduino Nano.

Teensy worked like a charm but there are some modifications that had to be done to Adruino software to make Teensy work. What do I do now? Try it on a different computer? :grin:

Thanks.

Same story. 1) Yesterday I tried to install a fresh copy of Arduino on a computer that never had it installed before... 2)tried different cables. 3)tried different computers 4)installed official FTDI drivers because Arduino instructions didn't work -- the device was not recognized at all.

Nothing works. I think that this error message needs to become it's own forum category under "Using Arduino".

Dear Arduino developers, please help!

RE: http://forum.arduino.cc/index.php?topic=210565.msg1545540#msg1545540

You recently started two topics about upload troubles. Are they essentially the same topic?

Or is this topic in regards to a different board?

I am using Arduino Nano with Atmega 328, the version 3.0.
I have only this one board.

I see that this “avrdude: stk500_getsync(): not in sync: resp=0x00” topic is very common and many users seem to complain about it.

Arduino provides everything for free, and as-is, but it would be nice if you guys addressed this issue a little bit better, either by fixing a software bug or by explaining how to correct this problem.

Thank you.
Vladimir.

I got that message before. What worked for me was uninstalling, reinstall, and DO NOT mess with the setup. Do not touch the COM ports or any preferences. It was driving me nuts. I would change the COM because it was used by something else, so i decided to just let it go o whatever it installs to, and it worked. Maybe that will help.

On my other board, I had to stop everything I was doing and terminate all windows I had up, close out arduino IDE, unplug USB, plug in USB, hit reset and try again, and that worked. Seeme each board I own had it's own personality!

Sorry for the mistake I made in wording.

Shorting [u]reset to ground[/u] and [u]RX to TX[/u] doesn't work.

Serial Monitor does NOT bounce back what I type in and I still get the: avrdude: stk500_getsync(): not in sync: resp=0x30

When I send a line of text with a serial monitor, an [u]RX LED blinks[/u] on the board but nothing else happens.

Changed COM9 to COM2 Serial Port 9 to Serial Port 2, both in WIndows 7 and in Arduino software. Nothing happened. Still doesn't bounce back.

Do I need to buy a new board?

Threads merged.

Does the computer make the device insertion sound when you connect the board?

Yes, it does.
I can see it in Devices and Printers. I could even change the Serial port number from 9 to 2, both in Arduino software and in Windows, but that didn’t change anything. Still doesn’t work.

Just to confirm... • You tried a different, known to work, USB cable • You ran a loop-back test (described in Reply #5) • At least once in the past you were able to upload a sketch to the board

[quote author=Coding Badly link=topic=210565.msg1548062#msg1548062 date=1389818866]

Just to confirm... • You tried a different, known to work, USB cable • You ran a loop-back test (described in Reply #5) • At least once in the past you were able to upload a sketch to the board

[/quote]

1)YES 2)YES 3)I DON'T remember, I bought this board a long long time ago


I think that Arduino needs to create an institute of FTDI problem investigation because this is what keeps this beautiful project from growing and engaging more people in it. Vladimir.

VT91: I think that Arduino needs to create an institute of FTDI problem investigation...

They have. There is just one part missing: how to identify when the board is unusable.

All the evidence indicates the board (specifically the FTDI chip) is damaged. You may be able to reprogram it using in-system serial programming (ISP).

I don't have an ICSP device. The board is "Arduino compatible" - not sure who made it, there is no signature of the manufacturer...

Personally I had a lot of problems with FTDI before I started messing with Arduino and I would not use it for anything. There is competing brand of IC that interfaces via USB and I know that some Ardunio replicas made in China use that.

So should I buy a genuine Arduino with FTDI or a Chinese replica with that other chip?

I had the same problem.

Presumed cause: Counterfeit FTDI chip on compatible Arduino Nano V3.0. Driver works fine, but maker of FTDI chip creates an update that prevents the counterfeit chip from working either purposely or incidentally.

So mine worked until I downloaded an update to the Arduino software, coincidentally while installing new Teensy 3.0 drivers.

I downgraded the FTDI drivers and now both work.

I uninstalled the driver and installed the older one, using your link. Still same story... Doesn't work.

Without knowing if this part ever worked, you could chase your tale until you give up on Arduinos and have it really be a defective part.

I have noticed a -lot- of places shipping parts without an antistatic shielding bag. The pink bag is NOT enough, it is only made not to generate static charge, but won't protect against it. I had a long email conversation with SainSmart after I received several items without any ESD protection. They sent me several 2.4GHz modules stuck in pieces of white foam wrapped in regular packing tape! In the conversation, it became clear very quickly that they have no knowledge of static charge, why it is bad, and how to protect against it.

I was never able to get them to work. The displays are all damaged. Some friends of mine ordered a bunch of the same display from SainSmart, same thing, no ESD packaging, none of them work 100%. Image on the screen nonexistent or seriously messed up.

I suspect that a lot of people just getting started are getting frustrated because they have problems getting things to work, assume they are just not getting it, and give up. When in fact it is defective, ESD damaged chips.

I think that Arduino needs to create an institute of FTDI problem investigation because this is what keeps this beautiful project from growing and engaging more people in it.

There certainly should be a FAQ.

http://www.ebay.com/itm/USBasp-51-AVR-Singlechip-ISP-USB-Downloader-for-Arduino-Bootloader-/251317483631?pt=LH_DefaultDomain_0&hash=item3a83b0786f

If I buy this device and it works, how should I use it to program Arduinos that have mafunctioning FTDI/ Replica Arduinos with fake FTDI counterfits and Arduinos that have no USB?

I have many projects that don't need USB connectors and I may use Arduino boards without USB...


We need a forum to discuss Arduino counterfeit, Chinese Arduino replicas and other Arduino-compatible electronics...

How will you make sure that programmer does not have a counterfeit FTDI chip?

Take a risk. I am sure that not all counterfeit chips are bad... Some are just as good as the original ones.

What programmer option in Arduino software do I use to deal with this programmer?

I had this problem today. I just let Win7 automatically troubleshoot the problem at Control Panel -> Devices and Printers, and that solved it for me.