Oled not firing up at all

Hi all,

So i received my oled screens yesterday, however, what seemed to be very easy is becoming a real headache.

I bought these oleds.

I connected as follows:
VCC <–> arduino uno’s 3.3V
GND <–> Arduino GND
SCL <–> A5
SDA <–> A4

(also tried SCL <–> Arduino SCL and SDA <–> Arduino SDA, the 2 ports above the AREF port).

I also tried with VCC <–> arduino uno 5V, and also tried an external 5V power supply which doesn’t work either.

Then i used the I2C scanner and found out the address is 0x3C, so i changed Adafruit’s example sketch to 0x3C instead of 0x3D.

When i upload the sketch to my board, nothing happens (i.e. the display does not even light up).

I’ve been searching for hours but couldn’t make it work :slightly_frowning_face:
I’ve seen many people using 4K7 pull up resistors etc but i don’t think that’s necessary with my display?

Also, upon connecting the VCC and GND, shouldn’t the display fire up (because mine remains completely off) ?

Many thanks!

I bought one of these from a seller on eBay.

Which library are you using?
I used the u8g2 library and tried the Hello World sketch.
Works just fine.
I used 5V.

Okay i was able to make it work. Apparently one of the headers pins was badly soldered. I fixed this and know it worked directly (using Adafruit's GFX library).