Opening title is displayed on page where the mouse cursor position is held

The opening title panel below is displayed based on where the mouse cursor resided.

image

I have two monitors, when I launched Arduino IDE 2.0 on screen1 then moved the mouse cursor to screen2, the opening title panel will be displayed on screen2 instead.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.

Hi @rickygai. Thanks for your report.

Are you still able to reproduce this bug with the latest version of Arduino IDE 2.x (currently 2.0.0-beta.12)?

If so, please submit a formal bug report here:
https://github.com/arduino/arduino-ide/issues/new?labels=type%3A+imperfection&template=bug_report.md

I already searched for existing reports of this bug and didn't find any.

hi ptillisch,

Yes, I am using "Arduino IDE Version: 2.0.0-beta.11-nightly.20210921", the splash screen still the same, displayed based on where the mouse cursor placed if you have two monitor screens.

Thanks for the update. Please give it a try with either the 2.0.0-beta.12 release or the latest nightly build.

There was a very significant change in the Arduino IDE 2.x through a big update of the underlying Eclipse Theia IDE framework since the version you are using. It is possible the bug was fixed by that update.

hi, I have tested both Arduino IDE 2.0.0-beta.12 and nightly 20211102 64 bit, both resulted in the same splash screen issues which shown at where the mouse cursor is placed.

Thanks for checking. That is definitely not a nice behavior.