OpenOCD 0.10.0 in IDE can't find the .elf file for programming

I’ve been fighting with the IDE for the better part of today trying to make support for the SAMC21 work. I’ve managed to get the Mattairtech core for the SAMC21 to compile my code, but I’m still having trouble getting OpenOCD to flash the code to my custom board via the Atmel ICE tool.

I’m able to recognize the chip via Atmel Studio, so I know that my hardware setup is working.

I’m using the Arduino SAMD core, with the Mattairtech core, and I have modified the Mattairtech platform.txt file to use openOCD 0.10.0 - the latest version added support for the SAMC21.

I’m getting the following error messages when I try to run Upload using Programmer…

Open On-Chip Debugger 0.10.0+dev-gf0767a31 (2018-06-11-13:36)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.org/doc/doxygen/bugs.html
debug_level: 2
Info : auto-selecting first available session transport "swd". To override use 'transport select <transport>'.
none separate
adapter speed: 400 kHz
cortex_m reset_config sysresetreq
Info : CMSIS-DAP: SWD  Supported
Info : CMSIS-DAP: JTAG Supported
Info : CMSIS-DAP: Interface Initialised (SWD)
Info : CMSIS-DAP: FW Version = 1.0
Info : SWCLK/TCK = 1 SWDIO/TMS = 1 TDI = 1 TDO = 1 nTRST = 0 nRESET = 1
Info : CMSIS-DAP: Interface ready
Info : clock speed 400 kHz
Info : SWD DPIDR 0x0bc11477
Info : at91samc21j18.cpu: hardware has 4 breakpoints, 2 watchpoints
Info : Listening on port 3333 for gdb connections
target halted due to debug-request, current mode: Thread 
xPSR: 0x61000000 pc: 0x000001b8 msp: 0x20008000
** Programming Started **
auto erase enabled
Error: couldn't open {C:\Users\DAVIDC~2\AppData\Local\Temp\arduino_build_151208/sketch_jul16b.ino.elf}
embedded:startup.tcl:477: Error: ** Programming Failed **
in procedure 'program' 
in procedure 'program_error' called at file "embedded:startup.tcl", line 536
at file "embedded:startup.tcl", line 477
the selected serial port at file "embedded:startup.tcl", line 477
 does not exist or your board is not connected

Any ideas why it can’t find my file?

Solved my own problem! Looks like the platform.txt file had an extra set of squiggly brackets around all of the OpenOCD commands. Removing those fixed it. Case closed.