OpenWRT 1.6.2 and PHP

Hi, i've a question about OpenWRT 1.6.2 and PHP. On OpenWRT 1.5.3 i can install PHP and use it on Arduino YUN but with 1.6.2 version i can't. If i browse to PHP page i can download it but i can't see in browser. Is there a solution for this?

Thanks, Gabriele MagicBotolo

Same problem with me also. please help. :confused:

@magicbotolo, how did you install and download your PHP engine? Jesse

I have fixed this problem just now :)

The solution is to replace the contents of the file /etc/config/uhttpd with the following ( I got it from the previous 1.5.3 firmware ) :

# Server configuration
config uhttpd main

 # HTTP listen addresses, multiple allowed
 list listen_http
# list listen_http [::]:80

 # HTTPS listen addresses, multiple allowed
 list listen_https
# list listen_https [::]:443

 # Server document root
 option home /www

 # Reject requests from RFC1918 IP addresses
 # directed to the servers public IP(s).
 # This is a DNS rebinding countermeasure.
 option rfc1918_filter 0

 # Maximum number of concurrent requests.
 # If this number is exceeded, further requests are
 # queued until the number of running requests drops
 # below the limit again.
 option max_requests 2

 # Certificate and private key for HTTPS.
 # If no listen_https addresses are given,
 # the key options are ignored.
 option cert /etc/uhttpd.crt
 option key /etc/uhttpd.key

 # CGI url prefix, will be searched in docroot.
 # Default is /cgi-bin
 option cgi_prefix /cgi-bin

 # List of extension->interpreter mappings.
 # Files with an associated interpreter can
 # be called outside of the CGI prefix and do
 # not need to be executable.
 list interpreter ".php=/usr/bin/php-cgi"
# list interpreter ".cgi=/usr/bin/perl"

 # Lua url prefix and handler script.
 # Lua support is disabled if no prefix given.
# option lua_prefix /luci
# option lua_handler /usr/lib/lua/luci/sgi/uhttpd.lua

 # CGI/Lua timeout, if the called script does not
 # write data within the given amount of seconds,
 # the server will terminate the request with
 # 504 Gateway Timeout response.
 option script_timeout 60

 # Network timeout, if the current connection is
 # blocked for the specified amount of seconds,
 # the server will terminate the associated
 # request process.
 option network_timeout 30

 # TCP Keep-Alive, send periodic keep-alive probes
 # over established connections to detect dead peers.
 # The value is given in seconds to specify the
 # interval between subsequent probes.
 # Setting this to 0 will disable TCP keep-alive.
 option tcp_keepalive 1

 # Basic auth realm, defaults to local hostname
# option realm OpenWrt

 # Configuration file in busybox httpd format
# option config /etc/httpd.conf

# Certificate defaults for px5g key generator
config cert px5g

 # Validity time
 option days 36500

 # RSA key size
 option bits 1024

 # Location
 option country IT
 option state Turin
 option location Turin

 # Common name
 option commonname 'Arduino LLC'

Finally its alive |500x269

@Omar, thanks for posting the solution. I'm sure it will help others in the future. Jesse

thanks for posting the solution. I’m sure it will help others in the future.

You are welcome. Yes it will.