opkg update completely broken

Hi everyone,

As title says, I definitely can’t get the “opkg update” command to work properly. I always get the same error :
Downloading http://…/Packages.gz
Updated list of available packages…
Downloading http://…/Packages.sig
Signature check failed.
Remove wrong signature file.

I’ve been trying to find that “wrong signature file”, without success after trying the command again.
I also upgraded the image several times as usually advised, but still, every time the command fails.
Given that I can ping (for example) download.linino.org without a single problem, I’m completely lost.

Your help would be greatly appreciated.

Ok, commenting the line "option check_signature" in the /etc/opkg.conf seems to override the problem, but what are the consequences ?

What is content of

cat /etc/opkg.conf

Hello I am having the same problem on my Arduino Yun. I tried several times to run opkg update, I tried to reflash first with an image from Arduino website, then with a Linino image. Got same result: "Signature check failed". The ping to the update website is ok so no Internet connession issue. I also tried to comment the line "option check_signature" inside the opkg.conf file, but only got a different error. I read different posts about the argument but no one produced a working solution.

I was only able to manually download the package file I needed from the web, put it on a SD card and install it from there.

Is there actually a solution to this problem?

Thank you

Can you paste the output of opkg update? There is no solution because there usually is no problem on the yun side: if the signature check fails, then something went wrong when downloading the Packages* files

Hi, I have the same issue.

root@Arduino:~# opkg update Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.gz. Updated list of available packages in /var/opkg-lists/attitude_adjustment. Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.sig. Signature check failed. Remove wrong Signature file.

I can ping downloads.arduino.cc

please help.

Many Thanks

Please ensure your yun is connected to internet and retry

Cool thanks it's working now. :)