'opkg update' now working in USA

Thanks to the Arduino team, those at Linino.org, and their commercial support teams.
Just moments ago, I tested my Yún. It is operational. (See below.)

A later will write about my upcoming trek (from El Paso, Texas back to San Francisco, California)
(said to be 1,902 km) to show all leading developers of Silicon Valley my new love - Arduino Yún.

Cheers to all
Jesse

root@Arduino:~# opkg update
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.sig.
Signature check passed.

Well. It was working. Now it's broken again.

Jesse

Changes just made that improved the system. And now I can install list again.

NOTE: Yesterday I installed node.js to go around the issue with ‘opkg update’

Just now I deleted all node_modules in /usr/lib/node_modules

Then I made changes in the storage that opkg uses.

src/gz attitude_adjustment http://downloads.arduino.cc/openwrtyun/1/packages
dest root /mnt/sda2/root
dest ram /mnt/sda2/tmp
lists_dir ext /mnt/sda2/var/opkg-lists
option overlay_root /overlay
option check_signature

NOTE: The option check_signature is not documented on the openwrt. I commented it out and it DOES NOT check the signature.

TO BE CLEAR:

  1. The change to /etc/opkg.conf with the path seems to help.
  2. As a fallback, remove the option check_signature from /etc/opkg.conf

Happy installation, all.
It’s now 2am in Texas, and it is Christmas Eve.
Jesse

The work-around is causing other problems. DONT try this unless you like pain, or alot of reading. I need sleep.

Jesse

Setup Yun local packages repository, working on opkg update offline (without Internet, on board airplane)

Make sure turn off wifi of Yun and laptop when on board airplane!