Orange LED of hell

Hi,

i have the same problem as described in this post and this

I don't know what i have done wrong, but i can't communicate with my portenta anymore. The orange LED, which is connected to the fancy power supply IC, is on and turns off an on every ~15 seconds. I measured the input and output voltages of the power supply.

  • 5.0 V USB voltage is fine
  • VSYS are 4.18 V
  • +3V1SW -> not present
  • +3V3 -> not present
  • +3V1 -> available
  • +1V0 -> not present
  • +1V8 -> not present
  • +1V2 -> not present

The STM32 should work properly since it is powered by 3.1V, right? As in one of the other post mentioned, it seems, that the MCU have not powered up the power supply yet.

Probably something is wrong with the bootloader, so i decided to use the ST-Link and the breakout board to reburn the bootloader.

I also overcome the problem the the 3.3V are not present, but which is needed for the ST-Link as reference voltage for the logic level. Therefore i use an external power supply.

I have tried to use the Arduino IDE, PlatformIO and the STM32CubeProgrammer to get access to the MCU. But every time i try, i get an error that the target can't be found.
I have now checked several times whether I have wired the SWD connection correctly and I am very sure that I have not made a mistake here. Also i use the newest firmware version of the ST-Link and I updated the Arduino IDE and the portenta core files.

I don't know what i can do to bring the portenta back to life. Any suggestions?

You could share that information.


Sure! The two images show how i soldered the STlink connector to the connector on the breakout board. The cables between are as short as possible.
Maybe you can find an error :slight_smile:

Some ideas:

Are BOOT and BOOT_SEL dip switches set for upload?

Have you tried a simpler connection, use SWD only 4 wire - SWDIO, SWCLK, 3.3V, GND?

In which state should they be for upload?
I tried the SWD without the SWO connection. Maybe i will take an oscilloscope and see what is going on with the signals.

I can't remember, but I think you have to reboot with them in the right position, to access via SWD.

I just tried again the four combination of the BOOT and the BOOT_SEL dip, but the STM32CubeProgrammer doesn't find a target :confused: