Original GSM Shiled 2 debug

Hi there,
I have just bought an Arduino GSM shield and I would like to know why is not working.
My setup is: Arduino Mega ADK with IDE 1.8.3
I have connected the shield jumpering pin 10 with 2 on the shield and the male pin 2 is not connected to the Arduino
So if I upload the example sketch "TestModem" from GSM library in serial console I get: Starting modem test...  Starting modem test... Starting modem test... ERROR, no modem answer. Checking IMEI .... Modem's IMEI: 0 Resetting modem... Starting modem test...
And then remains stuck at these point. I have tried to reset but it doesn't seem to go on.
I have tried "ReceiveSMS" from examples and in serial monitor I get only SMS Messages receiver repeated some times.
It seems there is a problem with gsmAccess.begin because GSM never get initialized. I have tried this more than twenty times and only two occasions I was able to see GSM initialized waiting for messages but when I sent a SMS the console prints SMS messages receiver again some times and gets stuck.
So is my shield broken?
Is there a way to fix this? Is there a bug in GSM library?
Thank you in advance