OS X Yosemite 10.10.5 on MacBook Pro frequently crash using Arduino IDE

Hi, I am writing here, in this forum section, to have information or suggestion about continuously crash and reboot of my MacBook Pro with Yosemite 10.10.5 and Arduino IDE 1.8.8 (if this topic has already been dealt in the past, please, let me know where could I find information about).

Very rarely I have had lucky and the programming process straight ahead untile the end without problem. But, even in this case, when I have tried to open "serial port", it falls down in the grey-dead-screen.

I have tried to change "usb" driver both changing version (CH34x ver. 1.3, 1.4, 1.5), but even changing configuration process (doing manual installation steps). The results was the same.

This doesn't happen with Arduino UNO R3 board. It only happens with ESP-12 module (NodeMCU 0.9).

There is someone in this forum could help me?
Thanks in advance.



For people could have same problem: I solved it using CH34x driver version 1.3.


Thanks for taking the time to share your solution estro!