OS X Yosemite and Arduino ver 1.0.5

After installing Yosemite today a few of my apps will not launch... like Matlab...but that's another issue.

When I went to launch Arduino I was presented with the following message:

So after installing the suggested JAVA legacy install located here:


Everything worked fine.

So for those of you wondering if Arduino works on the GA version of Yosemite....yes it does 8)

Verified against ver 1.0.6 as well.

Does this fix revert to a less secure version of Java (ver 6) systemwide? Or will this only install a version for use with the Arduino IDE and co-exist with the newer version?


I bought an arduino uno recently. I tried to launch arduino and got the same message. However, when I click on the link (Download Java for OS X 2017-001), it doesn't work. It doesn't load anything. Why is that? Any ideas why?


What were your exact steps? The link to apple support loads a blank page.


The link is working once again.


The direct link to the install package incase the page doesn't load again.


Yes Arduino works, but have you tried to upgrade?

I also recently installed Yosemite and had the same problems.

I followed the links and reinstalled the older Java.

Now the Arduino IDE loads ok, but...

There are no boards listed when they should all be shown in a pulldown menu under the tools menu.

It's odd because the pulldown showing the ports works fine. Any ideas?


Ignore my last - problem solved.

I'd been using a dropbox folder as my sketch folder - so I can access my files on multiple computers.

When I set the sketch folder back to the one in the C drive documents folder, and restarted the IDE, it suddenly found all the boards again.

Somewhere one of the files it needs got moved or corrupted presumably.

Thanks anyway