OSEPP Uno Analog input pin question

Hello, I'm trying to make a little desktop excavator arm with 4 servos hooked up to 4 potentiometers. But I can't get the fourth servo to work. I hook three of them up to A0,2,4 and they work. But I can't get the fourth servo to work on pins A1,3,5.

I see there are broken lines on the three "working" pins but I can't find any documentation relating to what those mean. Swapping the wires to working pins shows I have it all wired up correctly and the code is good.

Any help on what those broken lines mean on the OSEPP Uno R3 Plus board mean would be greatly appreciated.

Have you tried this?

"Note: In our research we did find some users were having a slight issue when uploading code to their devices. Luckily OSEPP provided a response and an easy fix to this issue: “If your sketch does not load properly using the Arduino Uno selection, please select Arduino Duemilanove or ‘Nano w/ Atmega328.’” See the full tutorial for additional information."

https://www.circuitspecialists.com/blog/osepp-uno-r3-plus-vs-official-arduino-uno/

The wiring and coding all work fine. It uploads and executes the sketch as written, but the potentiometer hooked to any of the unbroken lines just maxes out like it can only do high and low

This is very unusual and the broken line graphics on your board are not the same as on some other OSEPP board images I see, so I don’t know what they represent. Certainly there is nothing on theOSEPP schematic indicating a difference.

It almost feels like a defective board. The ADC converter has a multiplexed input and the channel is selected among the 6 analog pins. It almost feels as if there is a defective bit in the selection register. That register is where the bits control the active channel is called ADMUX.

Run this little test sketch , and see if the selection values in ADMUX change appropriately

void setup() {
  Serial.begin(9600);
  //read A0 through A5
  for (byte i = 14; i <= 19; i++)
  {
    int val = analogRead(i);
    Serial.println(ADMUX, BIN);
  }
}
void loop() {}
1000000  //A0
1000001  //A1
1000010  //A2
1000011  //A3
1000100  //A4
1000101  ///A5

Will do after work, thanks for the suggestion and I will get back to you on it.

Your sketch worked (of course) and gave me the code you had written. Does that mean everything is theoretically working properly?

Turns out I’m just an idiot and forgot to change one of the labels. Hehehehehe Whoopsies! Thanks for all the assistance. Hope you get a chuckle like I did. All 4 servos are now working perfectly :smiley: