OSX 10.14.6 & WeMos Mini D1

having fun getting this blighter to work, have got around the USB driver chip issue (already had the drivers installed for another board) so no crashing when connecting.

got around the issue of it not funding why python hides itself by using the 2.5.2 version of the ESP boards (newer version refuse to find the python install from python.org)

plug in, with an empty programme thus

// WeMos D1 test

void setup() {
  // put your setup code here, to run once:

}

void loop() {
  // put your main code here, to run repeatedly:

}

and try to upload.

the little blue light on the board flickers a few times so something is happening, then I get this:

Sketch uses 257072 bytes (24%) of program storage space. Maximum is 1044464 bytes.
Global variables use 26540 bytes (32%) of dynamic memory, leaving 55380 bytes for local variables. Maximum is 81920 bytes.
esptool.py v2.6
2.6
esptool.py v2.6
Serial port /dev/cu.wchusbserial1420
Connecting....
Traceback (most recent call last):
Chip is ESP8266EX
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/upload.py", line 25, in <module>
Features: WiFi
    esptool.main(fakeargs)
MAC: d8:bf:c0:f9:b1:ff
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 2694, in main
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 460800
Changed.
Configuring flash size...
    detect_flash_size(esp, args)
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 2073, in detect_flash_size
    flash_id = esp.flash_id()
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 567, in flash_id
    return self.run_spiflash_command(SPIFLASH_RDID, b"", 24)
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 812, in run_spiflash_command
    old_spi_usr = self.read_reg(SPI_USR_REG)
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 475, in read_reg
    val, data = self.command(self.ESP_READ_REG, struct.pack('<I', addr))
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 332, in command
    p = self.read()
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 277, in read
    return next(self._slip_reader)
  File "/Users/dale/Library/Arduino15/packages/esp8266/hardware/esp8266/2.5.2/tools/esptool/esptool.py", line 1877, in slip_reader
    raise FatalError("Timed out waiting for packet %s" % waiting_for)
esptool.FatalError: Timed out waiting for packet header
esptool.FatalError: Timed out waiting for packet header

and frankly I’m stumped, had a poke on google and most answers seem to be to install the USB drivers and then everything works, or to grab python from python.org (which I did) or downgrade the board library (which I did)

board settings are pretty much the default as I have no idea what to change them to:

LOLIN (WEMOS) D1 R2 & Mini

the port is set right

“get board info” returns “unknown board”

Q: is there some variable or something I need to set?

Tried clicking options at random, setting the upload speed to 115,200 and now it works