OSX Yosemite not detecting Arduino UNO

Hi!

I updated my OSX version to Yosemite, and since then, my Arduino UNO no longer appears in the list of ports of the IDE. I can only see the Mac's own bluetooth ports, but no "/dev/tty.usbmodemXXXX".

In the Mac System Report, when I plug it, I can see it as an "Unknown communication device".

I already followed these steps:

  1. install any port drivers needed. (http://www.ftdichip.com/Drivers/VCP.htm)
  2. run this: sudo nvram boot-args="kext-dev-mode=1"
  3. Restart MAC

But no luck. I tested the arduino in a PC with Windows XP and it works like a charm.

Any advice? Thanks!

EDIT:

It appears now like an "Arduino UNO" in the system information, but still not listed in the Arduino IDE:

Arduino Uno:

ID del producto: 0x0001 ID del fabricante: 0x2341 Versión: 0.01 Velocidad: Hasta 12 Mb/s ID de la ubicación: 0x14100000 / 9 Corriente disponible (mA): 500 Corriente necesaria (mA): Desconocido (dispositivo no configurado)

Are you using official product or a compatible board? Most of the problem are caused by the signature of the driver in Yosemite. You can use CodeBencer.cc as a replacement.

Yep, I’m not using the original Arduino. I have a compatible board.
I’ll give https://codebender.cc/ a try!

Thanks :slight_smile:

The UNO doesn't use an FTI chip so that wouldn't help. I would try re-installing the IDE. Version 1.6.1 through 1.6.4 have been working fine on OS X 10.10.3 for me.

Good to know. Thanks!

Hi All

I have a similar problem to mattogodoy in that I cannot select anything other than…

Serial ports
/dev/cu.Bluetooth-Incoming-Port
/dev/cu.Bluetooth-Modem

…from the Port menu. The “Serial ports” option does not appear to make any difference when I select it.

It does not matter what “Programmer” I choose, the above options remain the same in the Ports menu.

I am running a SODIAL Arduino NANO…I didn’t know any better when I bought my first Arduino otherwise I would have likely gone through the Arduino store. Interestingly, I have had this baby working with my Mac before. I disconnected it a few days ago to try a different project but now I need to go back to the Mac and it don’t see the NANO anymore. :frowning:

When I take at look at the /dev directory, I can see the devices mentioned above, but the…

/dev/tty.usbmodemXXXX

…is not there.

I have tried reinstalling the Arduino IDE by…

a) Removing the directory /user//Library/Arduino15
b) Downloading the IDE again from arduino.cc

When the IDE starts, it recreates the Arduino15 directory along with the preferences.txt file.

Not sure if this is a bug in the IDE? Perhaps it should be reported as such?

Any help would be greatly appreciated. Can I manually create the appropriate…

/dev/tty.usbmodemXXXX

…devices?

Cheers