Page not working

This page
https://physics-lab.arduino.cc/activities/the-pirate-ship

appears to be not working.

Anyone knows something more?

Thanks

Did you register your Science Kit? It looks like they don't want people with clone kits to have access to the activities so if I try to look at any examples I get prompted to 'register my kit'. To register a kit you need the 'activation code' inside the box.

I am able to reproduce the issue of the page just being a spinning circle forever.

I also think it would be worth trying to log in if you have some sort of credentials with the Arduino Education system. I don't have anything like that so I can't try it out. And if you have purchased this product and are not getting access to the included resources then you should definitely contact Arduino support via this form:
https://www.arduino.cc/en/contact-us

However, this particular page is intended to be accessible to everyone because it is provided as the free demo sample of the Arduino Science Kit - Physics Lab product. So I'm certain that the fact that the page won't load is unintentional and the result of something broken on the website.

As a workaround, you can use this older copy of the page from the Internet Archive Wayback Machine:
https://web.archive.org/web/20200825210934/https://physics-lab.arduino.cc/activities/the-pirate-ship

1 Like

Yes, I've correctly registered my Science kit.
In fact, I can use all the other pages, but for this one out.

Thanks for your support.