Pas de réponse à la commande if (myNextion.init())

Bonjour,

Je me permet de créer ce nouveau post sur la réponse attendu du Nextion après le passage de la commande if (myNextion.init()).
J’utilise un Arduino MEGA 2560 et un Nextion NX8048K070_011.
Mon code fonctionnait très bien avant de devoir ré-installé mon Windows.
Après la remise en place de mes bibliothèques, impossible de retrouver le fonctionnement normal.
Je fait le tour des forums et de google en général mais sans pouvoir trouver la solution.
Après la commande myNextion.init(), j’ai systématiquement le retour Serial.println(F(“Nextion not responding…”)).

Je vous joint à mon post, les bibliothèques qui pourraient vous aidez à trouver la cause du dysfonctionnement.

Je vous présente un bout de code qui me sert de test dans le fichier test.ino:

Merci d’avance pour votre aide.
Signé Christophe

Nextion.cpp (8.72 KB)

Nextion.h (2.87 KB)

NexConfig.h (1.28 KB)

NexHardware.cpp (6.12 KB)

NexHardware.h (1.46 KB)

test.ino (1.34 KB)

Bonjour,
vérifie le câblage et l'initialisation en port série des sorties sur lequel tu branche le nextion

serial, serial2 .....

éventuellement change le

Merci pour votre réponse mais mon montage ainsi que mon câblage n'a pas changé. Mes commandes passe bien entre l'arduino et le Nextion. Le problème est au début du programme, avant, la communication ce faisait correctement pour avoir mon message "Nextion Ready..." et le programme envoyait le message au Nextion dans la zone de texte ta18.setText. => "Nextion - Arduino Ready"
Je ne comprent pas bien ce qui se passe, tous fonctionne bien hormis cette phase de test entre l'Arduino et le Nextion en début de programme. tous ça me laisse perplexe. Est-ce que la commande myNextion.init est vraiment utile? Frustration quand même car ça eu marché avant!!!