Pb afficheur LCD HELP MEEE

Bonjour a tous et a toute,
voila je viens de me lancer dans le projet Porte de poulailler automatique avec Arduino (hey oui il pleut pas mal et il fait froid en ce moment lol)
Malheureusement mon afficheur s’allume et n’indique que des carré noir, aucun dialogue et du coups je ne sais pas trop quoi faire

J’ai chopper le programme ainsi que le câblage sur un autre site qui m’a bien aidé mais la je ne sais pas comment faire

HELP MEEEE

j’ai mis le programme en pièce jointe

Pou voir la photo de l’afficheur voici le liens

https://www.casimages.com/i/210131092358879380.jpg.html

calculEphemeride.cpp (6.53 KB)

calculEphemeride.h (1.06 KB)

menu.h (688 Bytes)

poulailler.ino (19.5 KB)

RTClib.cpp (9.17 KB)

RTClib.h (2.93 KB)

hello
_as tu testé ton afficheur avec le prg "hello word" que tu vas trouver dans les exemple de la librairie?
_as tu reglé le contraste avec le potar à coté de l'afficheur?

bonjour,
j'ai testé le contraste avec le polar mais idem, je test aujourd'hui ou demain ta solution avec "hello word", sans changer le câblage au départ et si sa ne fonctionne pas je repars sur un câblage basic.

merci

L'affichage actuel est celui d' un afficheur alimenté mais non initialisé

c'est a dire "non initialisé" sans programme dedans? j'ai mis le programme utilisé en pièce jointe et arduino me confirme le televersement

j'ai mis le programme utilisé en pièce jointe et arduino me confirme le televersement

On te demande de faire les exemples de la bibliothèque, c'est trop tôt pour d'essayer ton code.
Le code des exemples est validé, il est fonctionnel.
Depuis le temps qu'il est dans le domaine public s'il y avait des erreurs elles ont toutes été corrigées.
Si cela ne fonctionne pas c'est la plupart du temps à la suite d'erreur de câblage ou de composants manquants.

Tant que tu ne réussiras pas à faire les exemples de la bibliothèque ce n'est pas la peine d'aller plus loin.

Le développement et la mise au point, quel que soit le domaine concerné, sont régis par les même règles : on teste point par point avant d'assembler et on ne fait que des tests unitaires (c’est-à-dire qu'on ne teste qu'une chose nouvelle à la fois).
C'est à toi de voir mais si tu veux bruler les étapes te ne feras que perdre du temps et tu finiras par te décourager.

Afficheur non initialisé = afficheur qui n’a pas recu correctement la séquence d’initialisation qui précède les données à afficher?

C’est souvent lcd.begin() qui s’en charge.
Ci cette ligne ne s’exécute pas correctement il subsite les rectangles noirs sur la première ligne d’un afficheur lcd.
.
Par ailleur la photo donnée plus haut ne permet pas de comprendre le câblage réalisé, câblage qui est peut être défectueux.

Comme indiqué par 68tjs : problème d’affichage → utiliser un petit programme d’exemple pour obrenir le fonctionnement de l’afficheur. Procéder par étapes.

hello
d'après ta photo, ton shield t'a été livré avec les pinoches non soudées

de ce que je peux voir sur la photo, il semble que tu ai câblé avec des fils "dupont" simplement glissés dans les trous prévus pour les pinoches ' que tu dois souder.

une fois les pinoches soudées, tu pourras enficher ton shield sur une UNO ou une Méga 2560

une fois ceci fait, tu n'auras plus de mauvais contact

bonjour dfgh , je dispose d'un arduino pro mini et non d'un Uno donc pas faisable de les superposer comme sa

68tjs et al1fch, je mis met demain je décable tout et recommence par tester le LCD keypad.

je vous tiens au courant et merci encore a tous de votre aide.

je dispose d'un arduino pro mini

Quelle version 5V ou 3,3V ?

5V 16Mhz

bonjour a tous,
j'ai tous recommencé en essayant de ne faire juste un message "Arduino TEST" et "Salut" mais .... le résultat est toujours le même (carré noir) même en changeant le contraste avec le potar

voici les photos de mon câblage ainsi que le PG dans les liens ci dessous

Pour info le fil orange branché sur VCC c'est mon + de l'alim 9V et le marron branché en GND c'est le -
et je n'ai pas connecté la résistance en A3

https://www.casimages.com/i/210202020810314197.png.html
https://www.casimages.com/i/21020202081136449.jpg.html
https://www.casimages.com/i/210202020811673471.jpg.html
https://www.casimages.com/i/210202020812353121.jpg.html
https://www.casimages.com/i/210202020812991476.jpg.html
https://www.casimages.com/i/210202020814389366.jpg.html

Bonjour,

68tjs et al1fch avez vous une idée? je me tire les cheveux depuis hier et je ne comprend plus rien

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.