Pertubation d'un DCF77 lié à l'alimentation (Arduino Uno)

Bonjour,

J’utilise un Arduino Uno R3 officiel avec un module DCF77 (pollin.de).
Quand j’alimente l’arduino en USB, tout marche nickel.
Quand j’alimente l’arduino en 9V sur prise jack, je perds ma synchro DCF77.
Si j’ai USB+alim USB, ca marche pas non plus.

Comme le DCF77 est très sensible aux perturbations électromagnétiques, j’en déduis que mon alim 9V (transfo chinois à 10 eur) m’envoi des perturbations.

Je précise que le DCF77 est alimenté en 3.3V, tout le reste de mon montage est en 5V.

Je n’ai pas d’oscillo pour visualiser la sortie de mon transfo.

Des idéees pour régler le problème ?

Cdlt.

rajoute des capas au niveau de l'alim pour supprimer les perturbations. Des selfs aussi le cas echeant.

tu as pas des piles pour tester?

Merci pour le retour.

Je viens de tester avec des piles (2 accus de 3,7 V en série soit 7,4 V). Ca marche nickel. Donc c’est bien le transfo !!!

Je mets quoi comme capa ? Simplement entre le + et le - ?

Cdlt.

bonjour, tu peux lire ce TUTO

Bonjour,

Tu pourrais essayer de mettre un 22µF en parallèle avec un 100nF céramique sur le 3.3V

Et bobiner le fil de liaison, cela formera une self à air , donc de faible valeur mais ce sera mieux que rien.

Ne pas confondre les rôles du condensateur :

  1. Quand il sert de réservoir de courant lors d’un pic d’intensité il faut réduire au maximum les longueurs de fil et l’inductance en série.

  2. Quand il sert de filtrage d’alim le montage fonctionne comme un pont résistif abaisseur de tension → c’est la même formule. S’il n’y a rien dans le fil série il n’y a aucun filtrage.
    Ce qui donne l’impression qu’un simple condensateur filtre le bruit ce sont tous les éléments parasites qui sont présents sans qu’on les invite mais le résultat n’est pas efficace.

C’est quoi ton alim chinoise ?
Elle délivre qu’elle tension ?
Le DCF77 consomme combien ?

Je te pose toutes ces question pour voir s’il ne serait pas possible de mettre une résistance en série dans l’alim ce qui formerait un filtre RC avec le condensateur.

J'ai acheté le même il y a deux semaines

Voici la doc qui est fournie avec le module.

La Stromaufnahme (consommation de courant, en teuton) est donnée pour 120 µA maximum sous 3,3V.

De mon côté, j'en suis en train de finaliser mes librairies de décodage du signal, ce qui n'est pas simple car celui-ci est souvent altéré.

Ce qui est sûr, c'est que la bestiole est capricieuse.

Je n'ai pas encore mis le doigt sur tous les facteurs qui peuvent brouiller la réception.

Certains me semblent clair : 1) la distance à l'émetteur : dans mon cas, je suis à un millier de km de la frontière allemande 2) l'orientation de l'antenne, obligatoirement perpendiculaire à la direction de l'Allemagne 3) le jour ou la nuit : la nuit le signal en sortie du DCF1 est bien meilleur que le jour

D'autres plus incertains : 4) l'environnement électromagnétique / perturbations radio 5) la position du récepteur dans ma maison : j'ai l'impression de perdre le signal en m'approchant de certains murs ou objets électriques.

Pour l'instant, je n'ai pas encore alimenté par autre chose que l'USB du PC.

Ce qui est intéressant, c'est de tracer une courbe temporelle de signal en sortie du DCF1, pour comprendre ce qui se passe.

Par exemple, quand le signal reste propre mais affaibli (plutôt en journée), les niveau bas sont stables, en revanche les niveaux hauts sont plein de micro coupures.

Par moments, le signal est clairement parasité, avec des fronts montants un peu n'importe quand, de manière plus ou moins régulière (régulière = écho ?).

Bref tout ça pour dire que si tu veux mettre en évidence une différence de comportement du module DCF1 selon la nature d’alim, il faut t’assurer que tous les autres facteurs sont identiques.

Récepteur exactement au même endroit, orienté pareil, et tous les tests faits à peu près au même moment de la journée, dans le même environnement électromagnétique.

faut dire que les transfo en general en CEM, c'est ce qui fout la mer... surtout si il sont chinois, mais en gros faudrais connaitre la frequence se découpage de ton alim, et faire un filtre RC simple pour eliminer cette frequence.

Malgré avoir fait allemand deuxième langue ( il est vrai cas désespéré donc dernier rang au fond chargé de l’animation :slight_smile: ) je ne comprends rien a la doc.

Je te fais confiance pour “S**tromaufnahme” ( à vos souhaits !) et donc au 120µA max sous 3,3V

La tension nominale est de 3,0 V (ça j’ai compris).
Si, comme on peut le supposer, l’alim fourni 3,3V on peut perdre 0,3 V dans une résistance en série.
Soit Rmax = 0,3/ 120 e-6 = 2500 ohms.

Je pense que 1000 ohms seraient bien suffisant avec un condensateur entre 1µF et 10 µF
Avec 1 µF, RC = 1ms, soit une fréquence de coupure égale à 160 Hz.
Cela me parait pas mal.


Tau = RC → c’est un temps, Tau s’exprime en seconde
oméga = 1/Tau → oméga s’exprime en radians par seconde
F = omega / (2
PI) → F s’exprime en Hertz


Schéma pratique :
Il y a 2 condensateurs parce qu’un condensateur n’est bon que dans une gamme de fréquences :
Fréquence basse : grosses valeur de capa → technologie chimique ou tantale.
Fréquences élevées : le précédent à trop de pertes pour êtreefficace on utilise un “petit” 100 nF technologie “céramique”.

DCF77.png

tu peux utiliser un Tore et enrouler le fil d'alim autour, ou des ferites, comme ceux utilisé parfois sur certain cable usb, ou appareil photos pour suprimer des perturbations.

Génial toutes vos réponses. Merci.

Si je comprend bien, on filtre l'alimentation du module DCF77 avec le montage de 68tjs. On ne fait rien sur l'alim chinoise ? Ou on fait les 2 mon capitaine ?

Je vous trouve plus d'info sur l'alim en rentrant.

Pour Bricoleau : c'est vrai que le DCF77 est sensible. Je suis à Paris en plein canyon urbain (intramuros) dans un immeuble en béton armé avec fenêtre au sud (l’émetteur est au nord est). Jusqu'à présent, je mettais mon install sur le balcon pour capter tant bien que mal. Par hasard, j'ai commencé à capter le signal en intérieur à plus d'1 mètre de la fenêtre. C'est vrai que la position du module ne bouge pas d'un iota et si je change son orientation, ca marche plus. (en fait, c'est en enlevant l'alim et en passant sur USB seulement que ca a commencé à marcher). (Pour mes tests avec usb, pile et alim, l'antenne ne change pas de place). Tu as du voir les autres travaux sur le décodage du signal DCF77. J'utilise la librairie de base pour l'instant. Je partagerai mon code d'ici peu, le temps de fignoler mon projet.

tu peux utiliser un Tore et enrouler le fil d'alim autour, ou des ferites,

Tout à fait .

Ou on fait les 2 mon capitaine ?

C'est à toi de voir : c'est toi qui es aux manettes. Cette bébette a l'air capricieuse ce qui rend les conclusions délicates. Si j'ai 1 conseil à donner : en environnement de mise au point aussi mouvant il ne faut jamais hésiter à remettre en question les conclusions passées.

Hello,

Pour l'alim c'est un petit transfo noir avec une led verte dessus. Au dos, on peut lire : AC/DC adapter, model SP-888 Input 100-240 VAC 50/60 Hz 0,3 A Output 9V DC 1A

Rien de bien précis de plus à vous communiquer.

Je vais essayer une ferrite que j'ai dispo et je vous dis.

tu aurais pas un petit transfo de telephone en USB genre samsung ou iphone ou autre, tu le branche sur le secteur d'un coté et de l'autre a l'arduino... que ce passe t-il?

hazerty565: tu aurais pas un petit transfo de telephone en USB genre samsung ou iphone ou autre, tu le branche sur le secteur d'un coté et de l'autre a l'arduino... que ce passe t-il?

==> Quand j'alimente par USB depuis le PC ou par un transfo 220->USB, ca marche nickel.

Quand j'alimente par pile sur la prise jack, ca marche aussi nickel. Donc c'est pas la conversion de tension qui foire mais bien le transfo.

Je vais avoir un oscillo sous peu, je vous posterai le screenshot du signal d'alim.

Bonjour,

Voici le screenshot de la tension 3,3v entre l’arduino et le module DCF : http://imgur.com/igItMFa

Le signal est le même que j’alimente en USB ou avec mon transfo chinois.

Je ne suis pas expert mais je ne vois pas de différence et je n’ai pas l’impression que le signal soit perturbé !

Vous en pensez quoi ?

PS : le signal 9V a vide et en charge du transfo chinois a exactement la même tête.

comme je dis, la tension peut être bonne, la même, mais comme ton module DCF c'est de la "radio" ils se peut qu'il soit perturber, par un signal parasite.

Tu dis qu'avec l'USB ou avec une pile il n'y a aucun soucis.

ESt ce que tu as tester la même chose, en alimentant ton module avec l'usb ou une qui marche, et avec ton alimentation chinoise allumé a coté, mais pas branché sur ton installation.

il faudrait que tu alimentes quelque chose d'autre, peut importe, avec ton alimentation chinoise, qui se trouve juste a coté de ton module voir si c'est ton alim chinoise qui perturbe ton module ou pas.

La fréquence porteuse est de 77,5 kHz (désignée aussi par sa longueur d'onde de 3,868 km). Le seul défaut de cette fréquence est d'être très sensible aux parasites.

On le remarque notamment avec l'augmentation de la portée à 2 000 km3 la nuit (car il y a beaucoup moins de parasites la nuit que le jour, et la nuit, l'ionosphère devient réfléchissante pour cette fréquence).

Bonsoir,

Pour le transfo, il est sous la table, a environ 70cm de l'arduino et est tjrs dans la prise multiple. J'ai un deuxième arduino alimenté avec la même alim posé à coté et aucun soucis quand j'alimente en usb. Donc pas d'effet parasite hors branchement. Je vais continuer de tester les differente combinaisons en essayant d'isoler le parametre en cause. Merci pour ton aide.

Et je confirme, je capte un bien meilleur signal la nuit que le jour.

J'ai branché l'oscillo sur la sortie du module DCF77. On voit bien le pulse de 100/200 ms toutes les secondes, mais c'est bardé de parasites.