Photo interrupter (5v) + arduino fio (3.3v) ?

Bonjour,

je souhaiterais connecter une fourche optique (récupérée d’une imprimante cassée) sur une carte arduino Fio. Mon problème est que la plupart des montages que je vois utilisent des fourches necessitant une alimentation de 5v sur des cartes arduino de 5v (telle la UNO).
Alors comment utiliser une fourche optique de 5v sur arduino Fio (3.3v).
Dois-je changer les valeurs des resistances par exemple?
Un exemple de montage que j’ai trouvé sur le web:
http://www.mon-club-elec.fr/pmwiki_mon_club_elec/pmwiki.php?n=MAIN.ArduinoInitiationEntreesOnOffOptoFourcheTestSimple

Merci d’avance pour votre aide.

Bjr, Il existe une multitude de méthodes pour adapter les niveaux logiques. Tu peux lier le topic suivant : http://forum.arduino.cc/index.php/topic,33143.0.html Tu peux également faire une recherche sur le net et tu auras de quoi lire toute la journée. @+ si tu as des soucis

Dans ton lien il n'y a que très peu de choses à changer pour passer en 3V :

  • côté émetteur infrarouge, 3V signifiera moins de courant vs 5V, donc il faut adapter la résistance pour délivrer le courant suffisant.

-côté récepteur : rien à changer si tu relis la résistance de 4.7k au 3V, le signal sera évidemment en 3V

Merci pour vos réponses. Un courant de 3v est alors suffisant ? Il suffit alors de changer la valeur de la resistance, ici en l'occurence 150ohms au lieu de 270ohm. (3.3v - 1.1v)/0.015=150 par excès. Pour les détails: http://www.mon-club-elec.fr/pmwiki_mon_club_elec/pmwiki.php?n=MAIN.MaterielCapteurIRoptofourcheLTH301-07

Par contre je ne connais pas la marque de ma fourche puisque récupérée et sans nom, donc pas de datasheet. :(

Ce n'est pas vraiment important dans le sens où d'une part le risque de griller quelque chose est quasiment impossible, et d'autre part ce n'est pas un composant très exigeant dont les caractéristiques varient d'un modèle à l'autre.

Ok, encore merci B@tto. Je vais tester tout cela en fin d'apres midi, je vous tiendrais au 'jus' :) Bonne journée.

Parfait, j'ai réussi mon premier test en faisant clignoter la led interne de la carte (pin 13) en coupant le faisceau de la fourche. D'ailleurs par chance j'ai trouvé le datasheet de ma fourche récupérée sur une imprimante. La voici :

http://rohmfs.rohm.com/en/products/databook/datasheet/opto/optical_sensor/photointerrupter/rpi-441c1.pdf

Au vue de ses caractéristiques techniques pourrais-tu me dire si le choix des résistances (150 ohms et 4.7 Kohms) est optimal avec l'arduino Fio (3.3v)...

Par ailleurs, j'ai un autre problème que j'ai posté dans la rubrique moteur du forum mais je n'ai toujours pas reçu de réponse satisfaisante... je fais une redirection vers ce post au cas ou :)

http://forum.arduino.cc/index.php?topic=180224.0

Encore merci à vous

Il suffit d'étudier la datasheet : 50 mA. Donc à 3V : R = U/I = 3/50 = 60 ohms. Après c'est le courant maximal admissible, donc ne surtout pas prendre en-dessous. Mais même à 150 ohms ça devrait très bien marcher ;)

Pour ton soucis de L293 : comme suggéré, peut-être qu'il est mort. Sinon mauvais câblage.

J'ai changé le composant L293D, mais le problème persiste. Le moteur tourne toujours lorsque l'alimentation externe est déconnectée. Il s'agit d'un problème câblage mais je ne vois pas où. Dois-je connecter ensemble Enable 1 (broche 1), Enable 2 (pin9) et Vss (pin16) sur la pin 3.3V de l'arduino Fio lorsqu'on utilise une alimentation externe 5V pour le moteur ???

Rappel: J'utilise un petit moteur pas à pas bipolaire de 4 + L293D + Arduino Fio alimenté par une lipo 3.7v + alimentation externe de 5V pour le moteur (reliée à la broche 8 du L293D). J'utilise l'exemple "stepper one revolution" comme sketch.

Lien vers le schéma de cablage : http://img15.hostingpics.net/pics/844159L293DFioWiring.jpg