Phototriac VO3023

Salve a tutti,
sto provando a switchare dei piccoli carichi (luci a led) tramite questi fotoaccoppiatori VO3023 (con carico massimo 1A) http://www.vishay.com/docs/84132/vo3020.pdf
Ne comando otto direttamente con arduino, utilizzo una resistenza sul led del fotoaccoppiatore di 360 Ohm (ne ho usate diverse fino a 1K Ohm) ma quando metto in LOW il pin alcune restano accese per poi spegnersi dopo un po' di secondi.
Da che dipende? Può darsi che il carico sia troppo basso?

Grazie a chi saprà aiutarmi.

B.

Quei "cosi" non sono fatti per comandarci direttamente dei carichi (a meno che non stai sui 100mA massimi), perche' hanno una dissipazione schifosa e si cuociono troppo facilmente ... di solito li si usa per pilotarci direttamente altri triac di potenza, mantenendo la parte AC isolata galvanicamente da quella DC ...

Inoltre, essendo appunto triac, non sono adatti a pilotare carichi in continua come i led, perche' il triac si "spegne" ad ogni passaggio per lo zero dell'alternata, se li usi in continua, rimangono accesi una volta innescati, finche' non togli alimentazione ... se vuoi mantenere l'isolamento ottico, per carichi in continua ti servono dei rele a stato solido specifici per la DC, e non per l'AC ...

Se invece li stai usando in AC, ed i led sono alimentati tramite condensatore passante, non va bene usare i triac perche' non gradiscono i carichi capacitivi, e spesso autoinnescano ...

EDIT: e se li stai usando a tensione di rete, lascia perdere, oltre a non poter funzionare correttamente, il regolamento ci vieta di discutere di modifiche agli impianti ed applicazioni pericolose ... in quel caso mi spiace ...

Grazie per la risposta. Eppure nel datasheet è indicato 1 A :confused:
Comunque i led sono alimentati con AC poi hanno un rettificatore ac/dc che converte la corrente in continua.... Non credo vi sia un condensatore nel rettificatore ma solo un ponte diodi.
Il discorso comunque è che per alcuni funziona per altri no. Soprattutto dopo che è in funzione per un po' di tempo.

Non sono in tensione di rete.

Grazie lo stesso.

B.

Sul datasheet e' indicato 1A. ma e' il valore massimo assoluto, per sicurezza bisogna sempre stare sul 65 / 70 % di quel valore come massimo per l'uso normale ... poi siccome il componente non ha un pad di dissipazione, i circa 3V che cadono al suo interno producono abbastanza calore da surriscaldarlo se non si sta bassi ... inoltre sarebbe sempre da leggere tutto il datasheet, non solo alcuni dati, per capire i limiti del componente, perche' se leggi "dissipazione 300mW", capisci che 1A non lo puo reggere in realta' come carico, dato che 1A su 3V di caduta interna farebbe 3W, non 300mW ... bisogna tuttavia ammettere che spesso i datasheet non brillano per chiarezza e semplicita' di consultazione :smiley: