PHP in an arduino YUN

HI!! I'm trying to install php in an arduino YUN but I really do not know where to write opkg update opkg install php5-cgi

The documentation says via YunSerialTerminal .. But how do I get access to that terminal I tried with http://arduino.cc/en/Tutorial/YunSerialTerminal but nothing happened .. Other post says in the Yun's command Linux command line... But again how do I get access to that command line..

I have installed a sd card and works fine. I access by 192.268.1.104/sd and I can see my files , and I can run .html files .. But I need to run php files . If I go to the serial monitor and type the commands nothing happened. please help

Use the yunserialterminal example sketch. I believe it is under the bridge example.
If you are on windows you can use putty to ssh to the yuns IP address.

Thanks noblepepper I tried http://arduino.cc/en/Tutorial/YunSerialTerminal but nothing happened . I'll try with putty

I ran putty and ask for hostname 192.168.1.104 then in next screen login as: arduino then arduino@192.168.1.104's password: xxxxx Access denied . Arduino and xxxxx are used when login in 192.168.1.104.. What login and password should I use ??

You need to log in as user root, password is whatever you set I to. Default password is Arduino IIRC.

Nobleppeper THANKS !!! I think I have installed. I received this messages from putty

Package php5 (5.4.17-1) installed in root is up to date.
Package php5-cgi (5.4.17-1) installed in root is up to date. …

I let you know

Noblepepper . Thanks again.. But I'm not being able to run a php program. Once I installed php in my server I ran the following commands: uci set uhttpd.main.interpreter=".php=/usr/bin/php-cgi" uci set uhttpd.main.index_page="index.html index.htm default.html default.htm index.php" uci commit uhttpd sed -i 's,doc_root.,doc_root = "",g' /etc/php.ini sed -i 's,;short_open_tag = Off,short_open_tag = On,g' /etc/php.ini Restart uhttpd with the command /etc/init.d/uhttpd restart (**)

(****) I do not know how to restart uhttpd where should I write those statements.... in putty?) What I did was turn of and start my arduino.

I went to 192.168.1.104/sd/test/test.php and it opens sublimetext which I have associated to my php files.

SO it is NOT going to the php processor

I haven't played with PHP so I can't help you there but you are at the point that some of the other posts about PHP should be useful.

There are several ways to restart a daemon, you can use the Luci web interface through System->Start up or you can use root@linino:/# /etc/init.d/uhttpd restart in the ssh session in putty. Rebooting will also accomplish this so you restarted uhhtpd when you turned the Yun off and back on.