PHP / Losing Serial Interface

Hi.. I have successfully been able to have PHP (v 5.2.8) send serial signals to an Arduino... I can repeatedly submit a PHP page and the commands work flawlessly.

If I reboot my Windows 2003 machine and then try and post the page, PHP does not display an error but the Arduino doesn't respond. I can open the terminal window and type in responses, so I know the Arduino has the program. If I then re-download the same software program, then I can send commands again from PHP.

Any help debugging why the serial connection is lost after boot-up?

I don't have a solution, but had a similar problem. I was using a serial connection between a bluesmirf, arduino, and my pc. When I reset my board (either using the button, or the serial monitor toggle), the serial connection would not work. However, if I downloaded the code fresh onto the board again, it would work fine again...until I reset...then have to download to work again....etc.

I recently ran the same exact code on an arduino mini, and now it works perfectly fine. I can reset to my hearts desire and the serial connection initiates fine. My guess is that it's something in the boot loader not resetting the serial connection properly when the board is reset. I would love to know for sure. :o

Thanks for answering... Glad to know I'm not the only one...

Over the weekend I soldered up an additional serial/ttl level shifter from modern devices using the FTDI chip. I disconnected my working arduino/php interface and hooked up the new level shifter. When I did that, the arduino/php interface no longer worked. I had to re-download the program to the arduino to get it to work again.

So, now I'm wondering if it is the level shifter? Could this possibly be the problem with your set-up as well?