pic atmega y bluetooth

ola amigos, espero se encuentren bien.

quisiera consultar con ustedes un problema que tengo con mi arduino, ya que tengo un pequeño programa para manipular un led via bluetooth, tengo en codigo de arduino que es este:

//////////////////////////////////////////////////////////////////////////////////////////////////
#include <SoftwareSerial.h>

/*
11, led
*/
int led=11;

char dato;
String readString;
void setup(){
Serial.begin(9600);
pinMode(led, OUTPUT);
}

void loop(){
leer_dato();

if(readString.length()>0){
if(readString == “on”){
digitalWrite(led, HIGH);
}

else if(readString == “off”){
digitalWrite(led, LOW);
}

readString = “”;

}
}

///funcion void leer_dato////

void leer_dato(){
while(Serial.available()) {
delay(10);

if(Serial.available()>0){
dato=Serial.read();
readString +=dato;
}
}
}

///////////////////////////////////////////////////////////////////////////////////////////////

y el codigo en app inventor el este:

no se como subir el programa de app inventor, pero el punto es que, envia los caracteres: "on" para prender el led y "off" para apagarlo, CUANDO EL ATMEGA 328-p ESTA EN LA PLACA ARDUINO EL PROGRAMA FUNCIONA BIEN, APAGA Y PRENDE EL LED, PERO CUANDO MONTO EL ATMEGA 328-P EN UN PROTOBOARD, EL LED NO PRENDE CON LA APLICACION AUNQUE el telefono si SE LOGRA VINCULAR CON EL MODULO, TOMO EL VOLTAJE DE 3.3V DEL ARDUINO PARA EL MODULO, Y EL ATMEGA LO ALIMENTO CON UNA BATERIA, DE 12V, PERO LO REGULO A 5V, (LA TIERRA DE LA BATERIA Y LA DEL ARDUINO LAS UNO TAMBIEN )

bueno ese es el problema que tengo ahorita, espero me puedan AYUDAR, ya que lo que quiero es que el bluetooth funcione con el atmega 328-p en el protoboard, y disculpen la molestia, les agradesco infinitamente el poco o mucho apoyo que me den, soy nuevo en este foro, pero cualquier cosa en que pueda apoyar con gusto lo hare, gracias.

y que esten muy bien :)

Para poderte ayudar, creo que deberías poner un esquema de conexionado del atmega en el protoboard. Puedes usar fritzing, por ejemplo, para hacer el esquema, que es un software gratuito.

Para continuar, la verdad, no sé qué tiene que ver el tema con "documentación", para que lo hayas puesto aquí. Yo lo veo más de hardware.

Para poner los códigos, se usa la herramienta "code". De los iconos que tienes arriba, encima de la zona en la que escribes los post, pues el 19, contando de izquierda a derecha.

gracias carmeloco y en verdad ofrezco una disculpa ya que es la primera vez que posteo algo y no sabia como, usar funciones especificas (como para postear el codigo asi como me sugieres), gracias por decirmelo :).

ya estoy preparando mi esquema en fritzin y lo subire, para ver si me pueden ayudar, segun yo estoy bien, pero si estoy en un error, en verdad se los agradeceria.

que esten bien y gracias por las sugerencias carmeloco :)

#4
Buenas tardes yo tengo el mismo problema, quisiera saber si lo lograron resolver, el detalle mio es que hago todo perfectamente el atmega en el arduino me agarra fino el bluetooth pero cuando lo pase a la protoboard ya no me funciona

Cierro este hilo porque ya tiene más de 120 días de inactividad. Y eso que el sistema te avisa con letras rojas! Por favor, pregunta otra vez iniciando un hilo nuevo.